Custom post type - editor content not saving but metaboxes, title and thumbnail saving correctly

Hi Folks, for my website http://illustratemedia.co.uk I have created a custom post type specifically for my partners page (http://illustratemedia.co.uk/partners). Everything works fine except the content in the editor. It is simply not being saved. I can't help but think something I have changed has caused this because two of the posts work fine but any new ones don't.

Even my metabox is saving! Could you please help?

Let me know if you need anything from me to look into this further.

Cheers,
Kyle

  • illustratemedia

    Hi Jack, here is the log I get everywhere on the site:

    Strict Standards: Declaration of CustomSidebarsVisibility::ajax_handler() should be compatible with CustomSidebars::ajax_handler() in /Users/kylenel/Documents/MAMP/htdocs/illustrate/wp-content/plugins/custom-sidebars/inc/class-custom-sidebars-visibility.php on line 901

    Warning: session_start(): Cannot send session cache limiter - headers already sent (output started at /Users/kylenel/Documents/MAMP/htdocs/illustrate/wp-content/plugins/custom-sidebars/inc/class-custom-sidebars-visibility.php:901) in /Users/kylenel/Documents/MAMP/htdocs/illustrate/wp-content/plugins/custom-sidebars/inc/external/wpmu-lib/functions-wpmulib.php on line 73

    Deprecated: Assigning the return value of new by reference is deprecated in /Users/kylenel/Documents/MAMP/htdocs/illustrate/wp-content/plugins/envato-wordpress-toolkit-master/index.php on line 207

    And this is what I get when I save a post:

    Strict Standards: Declaration of CustomSidebarsVisibility::ajax_handler() should be compatible with CustomSidebars::ajax_handler() in /Users/kylenel/Documents/MAMP/htdocs/illustrate/wp-content/plugins/custom-sidebars/inc/class-custom-sidebars-visibility.php on line 901

    Warning: session_start(): Cannot send session cache limiter - headers already sent (output started at /Users/kylenel/Documents/MAMP/htdocs/illustrate/wp-content/plugins/custom-sidebars/inc/class-custom-sidebars-visibility.php:901) in /Users/kylenel/Documents/MAMP/htdocs/illustrate/wp-content/plugins/custom-sidebars/inc/external/wpmu-lib/functions-wpmulib.php on line 73

    Deprecated: Assigning the return value of new by reference is deprecated in /Users/kylenel/Documents/MAMP/htdocs/illustrate/wp-content/plugins/envato-wordpress-toolkit-master/index.php on line 207

    Notice: Undefined index: authorship in /Users/kylenel/Documents/MAMP/htdocs/illustrate/wp-content/plugins/wordpress-seo/inc/class-wpseo-meta.php on line 451

    Notice: Undefined index: type in /Users/kylenel/Documents/MAMP/htdocs/illustrate/wp-content/plugins/wordpress-seo/admin/class-metabox.php on line 694

    Warning: Cannot modify header information - headers already sent by (output started at /Users/kylenel/Documents/MAMP/htdocs/illustrate/wp-content/plugins/custom-sidebars/inc/class-custom-sidebars-visibility.php:901) in /Users/kylenel/Documents/MAMP/htdocs/illustrate/wp-admin/post.php on line 233

    Warning: Cannot modify header information - headers already sent by (output started at /Users/kylenel/Documents/MAMP/htdocs/illustrate/wp-content/plugins/custom-sidebars/inc/class-custom-sidebars-visibility.php:901) in /Users/kylenel/Documents/MAMP/htdocs/illustrate/wp-includes/pluggable.php on line 1173

    Any thoughts?
    PS this is a brand new local copy of the site so that is why the directories are all local.

  • illustratemedia

    Hi Folks, I have just managed to get the saving to work again and some of the other odd things that were happening in the admin area have stopped too.

    It started working after I disabled revolution slider. Confirmed by turning on and off a couple of times and that definitely seems to be a trigger.

    Any ideas what might be happening there? I don't use revolution slider on the site so happy to leave it off but would be nice to expand my knowledge if anyone know what might have happened.

    Cheers

  • Jack Kitterhing

    Hi there @illustratemedia,

    Hope you're well today! :slight_smile:

    Headers already sent is quite a common warning, normally whitespace related in the mentioned php file, https://premium.wpmudev.org/blog/ten-of-the-most-common-wordpress-problems-and-their-solutions/ :slight_smile:

    As you mention the revolution slider, you might want to check the version and make sure it's up to date, because of http://blog.sucuri.net/2014/09/slider-revolution-plugin-critical-vulnerability-being-exploited.html

    It could be related. :slight_smile:

    Thanks!

    Kind Regards
    Jack.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.