Custom Post Type not Showing in Categories

Whenever I choose a category for a custom post type, that post does not appear on the specified category page. Is there something in particular I should be doing?

Thanks,

pgt

  • pgt
    • Flash Drive

    Yes, sorry.

    For example, say I create a custom post type called "Book." I create a new "Book" post and specify the category as "Novel." When visiting the category page for "Novel," my "Book" post does not show.

    Let me know if I should provide more information.

    Thanks!

  • pgt
    • Flash Drive

    Any advice? I feel this is a very simple support issue. Thus far, I'm pretty upset with my decision to go with WPMU Dev. I've ran into issues with every plugin thus far and end up having better luck with other plugins on the market :disappointed:.

    Custompress: Custom Post types do not show on category pages.
    Marketpress: Products do not show up in product listings, store, or actual product page.
    Membership: Images do not show for any membership level whenever downloads are set to be protected. Also cannot set but one email for the Paypal gateway (not an issue, just a feature I had hoped for).

    I understand these issues could be theme related, but that does not change the fact that I'm having trouble finding a reason why I paid for this membership or how I could continue. If it is/isn't theme related, support would be great to guide me in the right direction instead of modifying theme files that don't need to be.

  • aecnu
    • WP Unicorn

    Greetings pgt,

    I am sorry to hear that you are having such difficulty, from the sounds of the multiple issues you are having I've ran into issues with every plugin thus far these are commonplace to themes like Thesis, Genesis, and Salutations.

    Which theme are you running?

    Are you running the latest Custom Press version 1.2?

    Just trying to help figure this out and await your reply.

    Cheers, Joe

  • aecnu
    • WP Unicorn

    Greetings pgt,

    Sorry for the delay here. I have gone ahead and called in the lead developer of Custom Press to see if he can make heads or tails of this issue.

    Actually he is the new lead developer for Custom Press so it may take him a shot or two to dig in to figure this out if at all possible.

    Thank you for the info on this being a Theme Forest Theme, regardless we do try to work with and figure out all WordPress related issues here at WPMU Dev.

    Cheers, Joe

  • Arun Basil Lal
    • New Recruit

    Hello pgt,

    I just finished up the revised documentation for the new version of the plugin. Can you update the plugin to the latest version and give it a try?

    Ideally this should show up.

    If it still doesn't, please change your permalinks to "default" and then give it a try.

    If everything fails, please provide screenshots of the custom taxonomy settings (that you call "category") in good quality that its readable

    Will get this sorted asap. Apologies for delay.

  • aecnu
    • WP Unicorn

    Greetings pgt,

    We have not heard back from you as to the status of this issue.

    If you are still having an issue please let us know so that we may try to get you fixed up as soon as possible by choosing to check mark this ticket as unresolved below and posting any new errors or symptoms you are noticing.

    This action will also bring your ticket up front back in plain view again within the ticket system.

    Thank you for being a WPMU Dev member!

    Joe :slight_smile:

  • brandicoot
    • Site Builder, Child of Zeus

    I'm having this same issue. If I enable the built in category taxonomy for my custom post type, any attempt to view my custom posts by category results in a 404.

    Visit here to see what I mean... http://doitlocal.brandicoot.com.au/business_listings/brandicoot-2/
    If you click on the "featured posts" category link below the listing, it'll simply take you to a 404 - even though this category has custom post types associated with it.

    I have updated to the latest version and I've tried using the default permalink settings. Makes no difference though.

    Your help would be appreciated.

  • Arun Basil Lal
    • New Recruit

    Hello brandicoot,

    Can you confirm that you are using the latest version of CustomPress? And can you please check this with the default theme? You do not have to activate the new theme, just go to Appearance and preview the theme and see if it works with the default theme.

    Its working all perfecto for me, even with the default categories enabled, which I checked just now.

  • brandicoot
    • Site Builder, Child of Zeus

    I have updated to the latest version and I've tried using the default permalink settings. Makes no difference though.

    In addition, I now have a second issue:

    When I edit multiple listings simultaneously, custom field data is removed from ALL listings that were edited.

    In order to replicate this problem:
    1. Go to wp-admin/edit.php?post_type=my_custom_post_name
    2. check multiple check boxes
    3. From the "Bulk Actions" drop down, select Edit, then Apply
    4. Click the "Update" button (you don't even need to make any changes)
    5. Then view one of the listings that you edited and you will see that ALL custom field data has gone.

    This is potentially a disastrous bug. It could wipe custom data from thousands of custom posts with just a few clicks.

  • brandicoot
    • Site Builder, Child of Zeus

    Hi @Arnold

    Thanks for the reply. First of all, I gotta say what an awesome plugin this is. It's one of my favourites and it's great to see such logical thought go into the structure of it. Well done.

    Now, there are too problems that I'm experiencing:

    1. If I opt to use the built in WP taxonomies, the meta links produced by the WP loop don't work. They just go to a 404. Not a big deal because the custom taxonomies work fine and I'm quite happy to use custom taxonomies rather than the built in "Categories" and "Tags" taxonomies.

    2. Bulk editing custom posts, clears all the custom field data of all custom posts included in the bulk edit.

    I've attached screen shots of my custom posts settings screen. If you need any more info or you'd like me to set you up as an admin to take a look, I'm quite happy to set this up.

    Many thanks for your help.

    Chris

  • Arnold
    • El Macho WP

    Hi @brandicoot

    On the bulk edit thing. You can prevent that by editing the content-types.php in CustomPress/core. Search for doing_ajax and another || or condition to that if

    || isset($_REQUEST['bulk_edit'])

    that will prevent it from overwriting when bulk updating. This will be in the next release.

    On the taxonomy lists, most themes use get_the_category_list to display the categorries a post belongs to. 2011 theme does this. That only works for category however. To collect all taxonomies you need to use get_the_term_list

    get_the_term_list( $post->ID, array('category', 'speakers'), 'before text',  'seperator text', 'after text' );

    the array of taxonomy names used can be cllected with get_taxonomies

  • Arnold
    • El Macho WP

    You have to create your own page and query to get that to work. The built in pages in a template are too Post centric. When you use the built in Archive page there is an implicit post type assumed.

    For example a category search url looks something like
    example.com/category/favorites/
    A directory search would look like
    example.com/custom-category/something/
    You have to combine the categories to get them to cross over in your query. Hard to put two categories in an url. You can do it in your template query with some work. For example collecting all the categories that a listing belong to takes something like this

    //get related taxonomies
    $taxonomies = get_taxonomies(array(
    'object_type' => array('directory_listing'),
    'public' => true, 'hierarchical' => true
    ), 'names');
    
    $taxonomies = array_values($taxonomies);
    //Include Category
    $taxonomies[] = 'category';
    // Retrieves categories list of current post, separated by commas.
    $categories_list = get_the_term_list( $post->ID, $taxonomies, '', ', ', '' );

    They are called custom for a reason.You have to do custom work to retrieve them in combinations.

  • aecnu
    • WP Unicorn

    Greetings pgt and Chris,

    It appears the issues in this particular thread have been resolved and I am therefore marking it as such.

    @Chris thank you so much for good forum protocol by opening a new ticket for an issue that is not directly related to this issues reported in this thread.

    Thank you both for being WPMU Dev Members!

    Cheers, Joe

  • analyze
    • New Recruit

    I just downloaded the latest version of this plugin and have the same issue of not having any of the custom post types show up under the categories created and selected for these posts. the error message i receive is :

    "Apologies, but no results were found for the requested archive. Perhaps searching will help find a related post."

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.