Custom Press Permissions Problem

Hi

I have installed this plugin and am playing with it for the first time. I intend to use this for a staff directory and case study portfolio.

It looks great so far but I have fallen over at the first hurdle...probably something simple!

I have set up some custom post types with custom fields but am getting the following error when trying to add a post:

"You are not allowed to edit this post."

I am an Administrator and I have checked / assigned the Role Capabilities. I left most of the settings to default (particularly the ones that have health warnings - eg capability type).

PS. Having read some more threads, I ought to add that I am using the Genesis framework on this site!

Can you point me in the right direction.

Thanks

Mark

  • Patrick
    • Support Monkey

    Hiya @MolecularMark

    Welcome to the forums!

    Please double-check the following settings in the CustomPress post-type settings panel:

    1.) Pretty much everything in the "Supports" section :slight_smile:
    2.) Be sure the "Capability Type" matches the content type shown in the "Role Capabilities Settings", and be sure to click "Save this Role's Changes" for each role you edit there.
    3.) Be sure "Public" settings are set to default for now (you can edit later). In other words, "Display a user-interface for this "post_type" set to "True".

    Then try again. Please let us know how that goes.

  • MolecularMark
    • New Recruit

    Hi - thanks for your speedy response.

    I have double checked (and triple checked!) the settings you mention and everything is as required.

    Unfortunately, I am still getting the same permission error. :slight_frown:

    I have also double checked but I can add/edit default posts OK.

    Any other ideas?

    Mark

  • MolecularMark
    • New Recruit

    I had already tried going back to basics with 2012 theme and de-activating Genesis. It was not to do with that. I have no other role manager plugins / tweaks.

    Thought I had already tried Meta Map capabilities = true but, obviously not, as I just set that and it works!

    Thanks guys.

    :slight_smile:

    Now for some development...

    Mark

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.