Custom shortcode not working after update

I updated the Membership plugin to the latest and the custom short codes were not working. (I understand they are now a legacy thing) I worked around one of the issues, which was making a red ”click to watch full film” appear when the customer bought a subscription.

The issue is now with the green ”subscribe to stream” button which was wrapped in custom shortcode, which would make the green button hide upon a paid subscription, but appear when there was no subscription purchased.

Trouble is now that the green button always appears, and some users think they have to subscribe again, even tho they already did and the red button is available.

here is an example

http://greenplanetstream.org/all_films/the-next-best-west/

suggestions? Thank you

  • Patrick
    • Support Monkey

    Hi @greenplanetfilms

    Shortcodes are now tied to access levels. Go to “Membership” > “Access Levels” and you should see a column at the far right of the page where the shortcodes associated with each of your access levels are indicated.

    Simply replace your existing shortcodes with those corresponding to the minimum access level required to view your content, and you should be good to go.

    To make it real easy, you even have a shortcode that can be used to enable access to users who are not on a specific level. This is very handy if you want to enable access to all subscribers, except the level you specify. For example, to give access to all subscribers who are not on the “stranger” level, wrap your content in something like this:

    [not-level-stranger]CONTENT HERE[/not-level-stranger]

    Hope this helps! And thanks for being a member :slight_smile:

  • greenplanetfilms
    • Site Builder, Child of Zeus

    Hi Patrick, Thank you for refreshing my memory about that. I wish I applied that technique to the green button yesterday!…I think I was so anxious that all my content was exposed I wanted to address the red watch to play button first. So I edited all 90 posts. If I had my wits about me, and I did see that solution in other forum posts, somehow I did not think about the green button and how that would work with the new system. Word to the wise…if you are faced with editing every post, make sure you take the time to see if there are any other issues to address in posts since every one has to be opened, otherwise, like me, you’ll be doing the conveyor belt of edits again!

    End result: yes, adding the ”not” shortcode works. Now the SUBSCRIBE TO STREAM button does not appear if the user is logged in.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.