Custom Sidebars Pro causing backend posting issues

The latest update to custom sidebars pro has caused my site, http://www.washingtonexec.com, to have issues when updating any post or page...

We have has this issue before with past updates to the plugin and subsequent updates fixed the issue. Unfortunately, I don't know what this issue is. We have since deactivated the plugin in hopes of a new update soon.

Any help on this would be much appreciated!

  • Abdul Wajed

    Hi Drew,

    I hope you are well today. :slight_smile:

    I tried to regenerate the issue on my own test site with the default theme but I could not, able to update posts and pages without any issues.

    If I'm missing anything here, please correct me and provide with some more details on this and I'll be more than happy to assist you! I could tell you better about the fix if I could see it live, would you mind allowing Support Access so we can have a closer look at this?

    To enable support access you can follow this guide here:
    http://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Please let me know when you are done granting Support Access. I'll be looking forward to hearing back from you. Thanks!

    Kind regards,
    Wajed

    • Abdul Wajed

      Hi Drew,

      I hope you are well today. :slight_smile:

      Thanks for granting access. I have checked your site and I can see the updating page and post problem and the issue remains when Custom Sidebars Pro is deactivated. So it is certainly not an issue caused by Custom Sidebars Pro. So, could be caused by a theme/plugin conflict. Can you do a theme/plugin conflict test just to make sure no other plugin is causing it? Here's a nice flow chart for a generic conflict test: https://premium.wpmudev.org/wp-content/uploads/2015/09/Support-Process-Support-Process.gif

      If disabling all plugins fixed the error, then you know it is one of the plugins that is causing the error. Simply go through and reactivate one plugin at a time until you find the one that caused the issue.

      If this has no effect then we'll need to investigate it closer and unfortunately, there are no errors in the browser console. So, could you please enable WordPress debugging?

      To do this, please add following lines to the "wp-config.php" file of your site:

      define('WP_DEBUG', true);
      define('WP_DEBUG_LOG', true);
      define('WP_DEBUG_DISPLAY', false);

      Make sure that these lines are located above the "/* That's all, stop editing! */" line. Once they are there, please try to update post and page again and wait until it fails. Then use FTP or cPanel's "File Manager" tool to download the "debug.log" file from the "wp-content" folder of your site.

      Rename that file to "debug.txt" please and attach to your response here. If the file is bigger than 5MB it won't come through so in such case please upload it to some file storage service such as your own Dropbox or e.g. Google Drive account and share a download link with me here.

      Hopefully, that will give me some more information about what is happening.

      Kind regards,
      Wajed

  • Abdul Wajed

    Hi Drew,

    I hope you are well today. :slight_smile:

    I inspected the debug log but couldn't find anything related to this. I have checked your site again and do face the issue but not consistent and also behave differently in different browsers. I'm going to flag our second level support team here since this has been an off and on problem, to see if we can find a definitive reason and a definitive fix.

    Let's be proactive and get the second level team some log in details for your account so they can hop right in and look around.

    https://premium.wpmudev.org/contact/

    Subject: "Attn: Abdul Wajed"
    -WordPress admin username
    -WordPress admin password
    -login URL
    -cPanel/PHPMyAdmin credentials (username/password/cpanel login link)
    -FTP credentials (host/username/password)
    -link back to this thread for reference
    -any other relevant URLs

    Select "I have a different question" for your topic - this and the subject line ensure that it gets assigned to me.

    Meanwhile, I do find your max_execution_time is too low so could you please try increasing the max_execution_time, and then check whether that helps?

    You'll have to create a php.ini file in your root directory, and add the following rules in it:

    max_execution_time = 300

    The root directory is where /wp-content, /wp-includes, /wp-admin folders reside. You can check whether the values gets increased, or not via the WPMU DEV Dashboard, under WPMU DEV > Support > SYSTEM INFO

    If you aren't able to increase max_execution_time, would recommend you to get in touch with your host to increase these values behalf from your side.

    Have a nice day. :relaxed:

    Best regards,
    Wajed

    • Abdul Wajed

      Hi Drew,

      Thanks for sending over the credentials. So sorry to hear the inconvenience you have faced and probably it was a temporary 500 Internal Server Error because I am able to visit your site without any problem now. So please clear your browser's cache and check. If there's a problem with the cached version of the page you're viewing, it could be causing HTTP 500 issues. Internal Server Errors are not often caused by caching issues, but I have, on occasion, seen the error go away after clearing the cache. It's such an easy and harmless thing to try, so do it.

      And for Custom Sidebars Pro issue, I'm pinging one of our SLS (Second Level Support) guys as they are our code experts and will need advanced investigation. I believe, he will come up with his valuable feedback very soon.

      Please keep in mind, our SLS people work round the clock and they have to deal with lots of critical issues and other things. So it may take a little while for them to check this and provide a feedback. I appreciate your patience.

      Have a nice day. Cheers!
      Wajed

  • Lindeni Mahlalela

    Hello Drew,

    I hope you are doing great today. Thank you for being with us and for reporting this issue to us. I have logged in to your website and tried to create a new post and page in an attempt to replicate the issue but I could not as it seems I was able to create a new post and a page without issues.

    I also tried to use the Visual Composer as it uses a lot JavaScript hoping it will show some errors in console because of a conflict with Custom Sidebars Pro, but it worked perfectly without any issues. I may be missing something here so please correct me and give more information on how to replicate the issue.

    Please do not hesitate to let us know if you have further queries and we will always be happy to help.

    Have a nice day.
    Mahlamusa

  • Drew

    Hi Mahlamusa

    Thank you for looking into this issue.

    Unfortunately, after reactivating custom sidebars pro and whatever else was done in the backend, we are getting as notification from Yoast SEO saying our website cannot be indexed...

    Did you do anything with the wp-config file or .htaccess file on the servers?

    I am trying to troubleshoot this new issue...

    Thanks again for all of your help!

    Best,
    Drew

  • Lindeni Mahlalela

    Hello Drew,

    Thank you for the feedback and for your patience. I have looked into the new issue and it does not seem to be related to Custom Sidebars Pro, as the SEO notification from Yoast is there regardless of Custom Sidebars Pro being active or not.

    To answer your question first:

    Did you do anything with the wp-config file or .htaccess file on the servers?

    I did not do anything in wp-config or .htaccess, I only tested Custom Sidebars Pro in the WordPress Dashboard by adding new custom sidebars and trying to add a new page and a post, I marked those posts with "WPMUDEV Test" and have saved them as Drafts, but I have removed them now and deleted the sidebar I created. Anything that has to do with wp-config and htaccess, I did not do. If there are changes you don't recognize there, it might be my colleagues when troubleshooting other issues for other tickets, I am not sure. Also at this point, I wanted to check if there is anything in those files that look like changes made by my colleagues, I could not connect by FTP unfortunately, so I was not able to check.

    Now the issue about Yoast, I have clicked on the link on that notification and it took me to this page where I found the following:

    If Yoast SEO reports your site as not indexable by search engines, this can be caused by several reasons. At the same time, it's an issue of the highest priority, assuming that you want your site to be in Google's index.

    Please test the URL in Google's mobile friendly test here. If Google can run the mobile friendly test for the domain, Google can also spider the domain. In that case, the onpage.org warning is just wrong.

    I then tried their suggestion by pasting your domain in the Google mobile test tool
    , the results show that your page is mobile optimized:

    Which according to the Yoast error documentation, it means your page can be indexed and the notification on the dashboard is just wrong as quoted from the yoast page:

    In that case, the onpage.org warning is just wrong.

    The only thing that may raise a bad flag is that Google failed to load two resources from your website, saying the page was partially loaded because the two resources seemingly Google Analytics scripts were not loaded.

    This may be the only thing that may cause the Yoast tool to say the page cannot be indexed, but again this is wrong as Google can index the page.

    Now, I hope you understand that this Yoast issue is not related to the Custom Sidebars Pro plugin. Whether Custom Sidebars Pro is active or not, the notification stays there, the important thing is that Yoast documentation says that is wrong if Google can access and check your site for mobile compatibility.

    I hope this helps. Please let us know if there is anything else we can help with.

    Have a nice day.
    Mahlamusa

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.