Custom taxonomies not showing

I've been using a combination of MarketPress and CustomPress on Armed & Glamorous very successfully, but I've updated my theme and it seems to have broken it. My custom taxonomies (sleeve, retailer, colour etc.) are all visible on the CustomPress screens and seem to be correct, but they don't show on the product pages, and when I try to import a CSV file for new products (using ECI importer) my custom taxonomies don't seem to be registered.

I am using a child theme of Themia Lite, and I'm pretty sure that updating Themia Lite to the most recent version is what's caused the problem... any ideas what to look at /edit to fix the problem? It also seems to have lost my sidebar, even though the file and calls to that sidebar in the page template are still there.

  • sequin
    • Site Builder, Child of Zeus

    OK. Have solved the sidebar problem, which was a loss of widgetised areas (registered in inkthemes_functions.php) in the main Theme rather than in my child theme, so I'm guessing it's a similar problem with the custom taxonomies not registering after the update.

    Can anyone tell me where I would look for the custom taxonomies? I've been reliant on CustomPress doing all this for me but don't want to delete and reregister in custompress in case it loses any data.

    Also, if I wanted to register the new widgetised areas in my child theme rather than editing the original theme, how would I go about that?

  • Timothy Bowers
    • Chief Pigeon

    Hey there.

    If you go back to the last version of the theme it works again?

    So these custom taxonomies, where is the issue? On displaying the data in the front? Inputting the data in the back. I ask because you mentioned ECI and that it couldn't see them.

    If I can understand what's happening more clearly then i should be able to help :slight_smile:

    Also, if I wanted to register the new widgetised areas in my child theme rather than editing the original theme, how would I go about that?

    You would do that through the child themes function.php file, so you don't need to do that within the parent.

    Take care.

  • sequin
    • Site Builder, Child of Zeus

    Hi. Thanks for helping.

    Widgetised areas now sorted - I know these disappeared because I added these in the original theme so obviously these were overwritten when I updated - now in child theme.

    CustomPress seems more complicated and was added after the child theme, so shouldn't have been affected by that. The problem seems to be inputting the data in the back end. This is what I have tried:
    1. I can see my custom taxonomies from the Custompress menu in the back end. Nothing seems to have changed in the setup and they are all still associated with the post type "product".
    2. The menu for my custom post type is also missing.
    3. The taxonomies obviously still exist somewhere, as data appears correctly in the front end.
    4. The data entry fields for custom taxonomies has disappeared from the add, edit and quick edit product screens. I've checked the screen options tab and there is nothing left unticked,
    5. When I try to use the ECI csv uploader, it seems unable to recognise the custom taxonomies so I can't map the data to import new lines.
    6. I just tried to delete my custom post type, but it won't delete (asks me to confirm deletion, but then doesn't remove it.)

    Thanks

  • Timothy Bowers
    • Chief Pigeon

    Hey again.

    2. How do you mean? The admin menu?

    Or do you mean a menu on the front end which was made in:

    Admin --> Appearances --> Menus

    If so then when you swapped from parent to child they are classed as two separate themes so the menu needs setting again.

    I think it's hard to know whats going or on on there without taking a look. Do you think this would be possible?

    Can you please send in:

    - Mark to my attention
    - Link back to this thread
    - Include admin/network access
    - Include cPanel (I will need to look at the DB so need PHPMyAdmin or similar)
    - Include FTP
    - Include any relevant URLS for your site

    https://premium.wpmudev.org/contact/

    Thanks.

  • sequin
    • Site Builder, Child of Zeus

    Back again... I've just exported my custom taxonomies and imported them into a new site with a fresh install of CustomPress (version 1.3.3) and seem to have hit the same issue as before - the taxonomies show fine in the CustomPress admin screen but do not seem to be registered so I can't edit their values in the product admin or quick edit menus.

    My original site was working fine until I updated to 1.3.3 and I've now got the same problem there too.

    Where should I be looking to find the register_taxonomy etc code?

  • sequin
    • Site Builder, Child of Zeus

    Thanks Tim. MilkChic is now working but mystylecraving.co.uk is still having problems - the taxonomies are showing on the product menu but they are uneditable on the new product / edit product screens - either just the taxonomy title with no data entry box, or if there is content, an uneditable field. They do not show at all on quick edit.

    Can't figure it out at all.

  • sequin
    • Site Builder, Child of Zeus

    OK. I have a partial solution...ish. The taxonomies show on my products AND in the quick edit menu only when set up as hierarchical. Unfortunately I really want them to be non-hierarchical, but at least I can work like this temporarily. Any ideas for the fix very welcome indeed :slight_smile:
    Thanks

  • sequin
    • Site Builder, Child of Zeus

    No worries. Custompress still isn't working on mystylecraving.co.uk but I've managed to register the taxonomies manually (very proud of myself!). If you get the chance to have a quick look and figure out the problem I'd appreciate it but not urgent now, so only when you get a moment.

    Thanks for all your help!

  • Alexander
    • DEV MAN’s Mascot

    @sequin,

    Great job getting those taxonomies worked out! Tim has asked me to followup here to prevent any more delay, he's been incredibly busy with other things at WPMU DEV, and expresses his apologies for the delay.

    I just took a look, and I see you have the taxonomies working at the moment. As for getting CustomPress working again, there are a few things we can try.

    In fact, I've seen an issue very similar to this recently, if not even the same issue. Take a look at Arnold's post here:

    https://premium.wpmudev.org/forums/topic/custom-press-taxonomies-cant-be-checked-i-dont-know-what#post-429026

    I wanted to touch base with you first before trying anything. If you'd like to switch back to CustomPress, let me know and I can help. We'll just need to disable the code you put in place to register manually, and recreate the taxonomies in CustomPress.

    I'll be standing to assist however I can.

    Best regards

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.