Custom widget not appearing

Hi

I have bee trying to add a Custom Dashboard Widget with the Custom Dashboard Widget plugin.

The widget successfully appears in super admin dashboard but not in a directory users dashboard when Easyblogging is enabled.

Is there a way to rectify this?

Aslo, when selecting 'Execute content: Yes' the following appears in the widget content. What is this actually for?

Parse error: syntax error, unexpected '<' in /home/radlett/public_html/email/wp-content/plugins/custom-content-dashboard-widget/custom-content-dashboard-widget.php(116) : eval()'d code on line 1

Thanks

Nick

  • S H Mohanjith
    • Developer

    If you set 'Execute content' to 'Yes' content should be valid php code that can be executed. Can you post what you have set as the widget content?

    I'll check what's the issue with Easy Blogging is. Can I please know which version of easy blogging you are using?

    Thanks.

  • 3SixtyEvolve
    • New Recruit

    Hi Nick

    Greetings from the WPMU DEV Team!

    Thank you for using the Custom Dashboard Widget and for updating us on the errors you encountered. The Plugin is under active development, so we always welcome feedback from our Users.

    I think the problem to your first question (widget not showing in directory user dashboard) might have to do with your permission settings for users on the super admin dashboard.

    Let me know if this would help.

    Regarding the 'Parse error: syntax error'. I will follow up with the rest of the WPMU DEV Team and the Developer for an answer and revert back to you at the earliest with feedback and/or possible solutions.

    In the meantime, if you require any further assistance with any other topic/ plugin, please don't hesitate to be in touch.

    Gina :: Multiplicity
    Trying out as WPMU DEV Support Staff - Let me know how I go

  • harryhayes
    • The Incredible Code Injector

    Hi Guys.

    Ok, so no php in the custom widget hence the error so this issue is resolved. Thanks.

    I am using the latest version, (updated via auto update).

    I am unable to find any relevant permission settings so far. Any further help for this would be greatly appreciated.

    Thanks for you help

  • aecnu
    • WP Unicorn

    Greetings Nick,

    I am a bit confused as to you mentioned that the issue is resolved but you also later said:

    I am unable to find any relevant permission settings so far. Any further help for this would be greatly appreciated.

    Please give me a recap of the remaining issue.

    Thank you for being a WPMU Dev member!

    Cheers, Joe :slight_smile:

  • harryhayes
    • The Incredible Code Injector

    Hi Joe

    Apologies, There are two issue raised in this thread.

    The issue with the 'execute content' checkbox is resolved, however, I still need to resolve why the custom admin widget does not appear to registered directory users.

    It appears fine to me as super admin but not to users who register via the directory plugin.

    Thanks for you help.

    Nick

  • aecnu
    • WP Unicorn

    Greetings Nick and SRCenter,

    Following up on this ticket and the remaining issue within.

    I have tested two sub sites logged in as their administrators, not Super Admin, and the widget is indeed on the dashboard.

    Do you guys have the plugin network activated?

    Please advise.

    Cheers, Joe

  • 3SixtyEvolve
    • New Recruit

    Hi Nick and SRCenter

    I checked the settings myself and got the test custom dashboard widget to show. Since you couldn't get it to show, I thought I would just post some steps and screenshots here so that you can verify that your settings are correct.

    Multisite WordPress Setup
    1. Install the Easy Blogging Plugin and the Custom Dashboard Widget
    2. Don't network activate the Easy Blogging Plugin. Instead go to Primary Domain Admin Dashboard (that is linked to Multiste) » Plugins and activate the Easy Blogging Plugin.
    3. Go back to the Network Admin Dashboard » Plugins and network activate the Custom Dashboard Widget.
    4. Now go to Network Admin Dashboard » Easy Blogging and follow the settings on the screenshots below. (Easy Blogging 1, 2, 3)
    5. Now go to Network Admin Dashboard » Settings » Dashboard Widget and set up your Custom Dashboard Widget following my settings (See screenshot Custom Dashboard Widget 1)
    6. Go to Primary Domain Admin Dashboard where you will find the Custom Dashboard Widget that still needs to be configured. Configure it and save.
    7. Now go to your users and make sure that the right role has been assigned to each (I used subscriber level for the Easy Blogging access).

    And that's it. See my final screenshot with the results there.

    Have a good weekend and let me know if you have any further questions.

    Gina

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.