Customize page crashes one of my subsite admin

The Appearance > Customize page crashes one of my subsite admin. I don't understand why it is not showing anymore.
Can you please check if SSL insecure content plugin crashes Appearance-> Customise page? The insecure content plugin was installed by a colleague of yours and did the job but could it have caused it?

  • Nithin
    • Support Wizard

    Hi nick,

    I checked the dashboard, and I could notice the issue. I tested by disabling the SSL insecure plugin but the issue still exists when tested in my side, couldn't notice the issue being specific to SSL insecure plugin.

    This occurs due to multiple reasons because the REST API request is returning a 404 error and the returned headers don't include the "X-Requested-With" value, and hence causing this issue.

    It's more related to how the domains are mapped. The easiest workaround would be to enable the option mapped domain for Administration mapping under, Settings > Domain Mapping in the network dashboard.

    Which should ensure the dashboard loads via the mapped domain which in turn will load the customizer without any issue, and remove any CORS issue.

    Could you please check, and see whether the mentioned option helps? Other than that option, if you are looking to find the source of the issue, then I'm afraid it'll require plugin conflict test.

    Since I don't see you mention about conflict test, please do check the flowchart, and let us know how that goes too:
    https://premium.wpmudev.org/wp-content/uploads/2015/09/Support-Process-Support-Process.gif

    Kind Regards,
    Nithin

  • nick
    • Site Builder, Child of Zeus

    hi, i have set the " mapped domain for Administration mapping under, Settings > Domain Mapping in the network dashboard" .
    the dashboard works ok,( it used to work ok even without the last settings change).
    the issue is that the frontend has Internal Server Error even if i change theme.

    • Ash
      • WordPress Hacker

      Hello nick

      If you get internal server error while changing time, that is a different issue. It seems an error is generated by that time.

      Would you please enable debug mode and check if there is any error? To enable debug mode please go to wp-config.php and change

      define( 'WP_DEBUG', false );

      to

      define( 'WP_DEBUG', true );
      define( 'WP_DEBUG_DISPLAY', false );
      define( 'WP_DEBUG_LOG', true );

      Now recreate the server error. That will create a file called debug.log inside wp-content folder. Open that file, check the very bottom and you will see the latest errors. Please send me those.

      Have a nice day!

      Cheers,
      Ash

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.