customizing the appointments plugin

Hello!
First, I did not realize this plugin was part of the set..and I was THRILLED to discover it.
I want to make some design tweaks:
Can i change the color of the box for "Please click here to confirm this appointment" and the "confirm payment" button as well...they kind of get lost. Also, I don't really want the "not possible" wording to show...can I remove that (or make it white). Here is a link to the page I am working on: http://my-designs.net/make-an-appointment

thank you!

  • Dimitris

    Hey there Monica,

    hope you're doing good and thanks for reaching us! :slight_smile:

    Can i change the color of the box for "Please click here to confirm this appointment" and the "confirm payment" button as well

    You can use the following CSS rule in your theme options custom CSS section (if provided) or in a plugin like this

    .appointments-confirmation-button,
    .app_submit_btn {
      background: blue !important;
    }

    I don't really want the "not possible" wording to show...can I remove that (or make it white).

    The following CSS should do the trick here

    table.appointments-legend-table  td.class-name:last-child {
      color: white !important;
    }

    Warm regards,
    Dimitris

  • Monica

    Thank you! The first one worked perfectly and I love the new box color. (I made them red). But now I cannot read the text inside those boxes, so what code do I need to make the writing in the boxes to be white? (the confirm appointment and confirm payment).

    The "Not Possible" is still showing after i added that CSS. But that is fine...the next 2 things are more important.

    QUESTION 2
    Can I hide the "Show available times" right under the select a service - I am afraid it will be confusing to my people - I have instructions on that page so they will know what to do.

    QUESTION 3
    Can I change the text from "Please select a service" to "Please select a workshop topic"

    Thank you!

  • Adam Czajczyk

    Hello Monica!

    The first one worked perfectly and I love the new box color. (I made them red). But now I cannot read the text inside those boxes, so what code do I need to make the writing in the boxes to be white? (the confirm appointment and confirm payment).

    Please replace the first code that Dimitris shared with you with this one:

    .appointments-confirmation-button,
    .app_submit_btn {
             background:#75200E!important;
    	color:#FFFFFF!important;
    }

    It is already using the color that you set for a button and it's also setting the text color for a button to white (you may adjust it to your liking though).

    The "Not Possible" is still showing after i added that CSS. But that is fine...the next 2 things are more important.

    Could you please try this code instead of the one suggested by my colleague?

    .appointments-legend-table td:nth-of-type(5) {
      display:none;
    }

    Can I hide the "Show available times" right under the select a service - I am afraid it will be confusing to my people - I have instructions on that page so they will know what to do.

    The "Show available times" button is necessary because selecting a service from the list doesn't automatically update the schedule calendar by default. You can however change it by editing the "make-an-appointment-3" page and replacing the current

    [app_services]

    shortcode with

    [app_services autorefresh="1"]

    shortcode.

    That will remove the button and cause the site to automatically reload and load the proper schedule calendar upon service selection.

    QUESTION 3
    Can I change the text from "Please select a service" to "Please select a workshop topic"

    You can do this by adding "select" attribute to the shortocode. Together with auto-refresh option described above the shortcode to use would be:

    [app_services select="Please select a workshop topic:" autorefresh="1"]

    I hope that helps :slight_smile:

    Have a great day!
    Adam

  • Monica

    Hello!
    The first things worked perfectly - the text in the "confirm" boxes is white and jumps off the red background beautifully.

    I tried changing the code on the page as described above and get this showing up on the page:
    Warning: array_key_exists(): The first argument should be either a string or an integer in /home/content/p3pnexwpnas13_data02/04/3196604/html/wp-includes/cache.php on line 725
    And the "Show available times" is still there

    Thank you in advance for your help!

  • Dimitris

    Hey there Monica,

    hope you're doing good! :slight_smile:

    Could you please grant us support access to your website to see that in action?
    You can do so via WPMUDEV Dashboard plugin as described here
    https://premium.wpmudev.org/docs/getting-started/getting-support/#chapter-4

    Also, please keep in mind to use app_monthly_schedule like
    [app_monthly_schedule require_service="1"]
    after the services shortcode
    [app_services select="Please select a workshop topic:" autorefresh="1"]

    Warm regards,
    Dimitris

  • Monica

    Hello!
    Thank you! It is 90% perfect! Well when you first go to the page, this text is displayed under the "Select a Workshop"
    BUILD YOUR CUSTOM WORKSHOP

    1. Select Your Workshop Topic (read about them on the right)
    2. Select an available day – those in green are open
    3. Select available time – those in green are open
    4. Click “confirm this appointment”
    5. Click “confirm payment” – you’ll then be taken to PayPal. (note, if you click on the conifrm appointment again, you get a message that the time is not available)
    Please select a workshop topic:

    Warning: array_key_exists(): The first argument should be either a string or an integer in /home/content/p3pnexwpnas13_data02/04/3196604/html/wp-includes/cache.php on line 725

    When I click on day and time, it does not display the normal next step for confirmation...it just shows the same thing so I have to select day an time. When i do that the second time it works fine.

    But that is exactly what I want it to look like, so if you could fix that little glich, we'll be good to go!

  • Adam Czajczyk

    Hello Monica!

    Thank you for your replay!

    I have just tested it in three different browsers in both normal and incognito modes and I couldn't replicate that warning on your site. I think it's related to some caching though (as the warning message suggests) and also that this may be causing that further issue with no confirmation step for you.

    Please try following steps:
    - login to your site
    - click on "Managed WordPress" link in admin toolbar and select "Flush Cache" to clear cache
    - then clean browser's cache fully and check the booking again.

    Let me know please if that solves the issue.

    Best regards,
    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.