Custompress access

Does anyone else have issues posting custom content created with custompress? I do after the last update. But I’m not sure it’s due to custompress or an other plugin… But even my admin account is not authorized to post custom content…

  • Vaughan
    • Support/SLS MockingJay

    Hi @qlof

    thanks for the post.

    I haven’t heard of anyone having those kind of issues. not to say there aren’t any though.

    Could I just confirm you are actually using the latest edition 1.3.2.5 because it shows in the right column here that you are using 1.3.2.4

    I’ll try & test this shortly.

    thanks

  • Qlof
    • The Crimson Coder

    I’ve updated the plugin and the problem remains.

    The problem does not exist for normal Posts, only for the custom content.

    I have a User Role Editor plugin installed to enable Authors etc to be able to edit custom content. But not even the admin account has access to change or add custom content right now.

  • Qlof
    • The Crimson Coder

    I have tried resetting user roles and setting them for the reviews content type, but I am still “Not authorized to edit this content”.

    I have tried deactivating bbPress since it creates user roles for that, but without success. I’ve tried giving “key master” all access to the content type, without success.

    I have these plugins:

    Ultimate Branding

    WPMUDev notifications

    Akismet

    WP-Postratings

    Wordpress SEO

    I’ve tried deactivating all except for Akismet and it’s still not working.

    I would appreciate if someone could help out here…

  • Vaughan
    • Support/SLS MockingJay

    Hiya

    sorry for the delay,

    I have tested this issue, But I am unable to recreate the error, i can create post types as normal.

    Howver, could you try uninstalling the plugin completely (deleting all files too)

    then re-install it again from scratch. this may solve the issue.

    let us know how this goes.

    thanks.

  • Qlof
    • The Crimson Coder

    I have 400 articles with this content type that took a very long time to produce… Will the database entries be deleted if I deactivate and remove the plugin? I don’t want to remove the database tables containing these articles.

  • Vaughan
    • Support/SLS MockingJay

    hiya

    Sorry for the delay,

    If you de-activate the plugin, your data will be kept intact, but if you uninstall the data will be lost.

    Could you try using the default 2012 theme? Turn WP_DEBUG on in wp-config.php & see if there’s any errors at all.

    also it might be worth checking to see if there’s an error_log file in your public_html or root of your site (where wp-config.php is located)

    if you see an error_log file, can you possibly paste the contents of it if it’s not too large.

    I’m going to flag the developer on this, as I can’t replicate the issue myself. Hopefully the developer may have another thing to suggest.

    thanks.

  • Qlof
    • The Crimson Coder

    Hey.

    I have turned debugging on and changed the theme to the default 2012 theme. I've also deactivated and activated the plugin.

    The page I get stuck on is: http://domain/wp-admin/post.php

    Message is: "You are not allowed to edit this post."

    There is no message what so ever. The latest entry in the rror log is:

    [05-Mar-2013 12:15:38 UTC] PHP Warning: Illegal offset type in isset or empty in /home/qlof/30rap/wp-includes/post.php on line 1097

    It's an old error but it is repeted many times from that date. No other errors are there.

    See attached screenshot for settings.

    I don't remember if the error started after a plugin update, but I have updated the plugin once or twice after it started and nothing changed. I installed buddypress and everything was fine, but I still suspect this may be buddypress related. After installing BP each user has two roles, one for WP and one for BP. The admin user role is "keymaster" But I've tried changing the access for keymasters to all in the custom content type, without success…

  • Qlof
    • The Crimson Coder

    Ok I got it to work now, by turning on the “Map Meta Capabilities” option.

    “Capability type” was set to post, but I was able to post normal posts while I was not authorized to post the custom content type. So I believe the issue was with that…

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.