Custompress custom fields losing WP/plugins status

Hi, I had set up some custom fields for a post type, with wp/plugins statuses all set to 'yes' - all was fine. I then deleted that post type, leaving the custom fields behind. When I created a new post type needing those same fields, all the fields had reverted to 'denied', and I couldn't alter them.

Before I go ahead and recreate these fields, firstly:
1) Do I actually need to worry, if all I am going to do is use them in my (Thesis) custom_functions file? I'm a bit hazy as to when these fields stop being available to processing. I've been able to print them on my custom post-type just fine. Would I be able to sort teasers by them, for example?

2) Can I do something in phpmyadmin to change them back, perhaps?

Thank you for Custompress, I just love it, and it's helping me to understand WP mechanics!

  • Timothy Bowers

    Hey there, hope you are well.

    I don't have access to the Thesis theme so I wouldn't be able to fully support that. Of course if the theme is coded to WordPress standards then our plugin will help create theme template pages.

    I've been able to print them on my custom post-type just fine. Would I be able to sort teasers by them, for example?

    Do you mean like Excerpts?

    i would tell them we don't have the ability to really support thesis, but that the plugin will help create theme template pages for any theme coded to WordPress standards... 20:32
    but the first part of her question may be something to look into... 20:33
    if you delete a post_type and then want to recreate it, are you able to do so? 20:33
    and by teasers? does she mean excerpts?

    I had set up some custom fields for a post type, with wp/plugins statuses all set to 'yes' - all was fine. I then deleted that post type, leaving the custom fields behind. When I created a new post type needing those same fields, all the fields had reverted to 'denied', and I couldn't alter them.

    I've not had much experience with CustomPress myself (we have so many plugins), so this will be a good study for me. I'll grab a copy and get it installed to test the issue you have.

    I'll get back to you on this!

    Take care.

  • Timothy Bowers

    Hey again.

    I've just been looking at the issue you mentioned with:

    I had set up some custom fields for a post type, with wp/plugins statuses all set to 'yes' - all was fine. I then deleted that post type, leaving the custom fields behind. When I created a new post type needing those same fields, all the fields had reverted to 'denied', and I couldn't alter them.

    I was not able to recreate that... Perhaps I'm not following the same settings as you exactly.

    Can I please confirm which WordPress and CustomPress plugin you use?

    Do you think it would be possible for me to see the issue closer?

    Thanks.

  • Timothy Bowers

    Hey there, just checking in to see how things are going here? Did you get everything sorted?

    We haven't heard from you on this thread for a while, perhaps you got help over email. I'm going to presume your all fixed up now and don't need any further assistance.

    However if you have more questions or need some more help then please feel free to respond in this thread or create a new one and we will be more than happy to offer assistance.

    Take care.