CustomPress only showing "settings" and "export/import" on multisite

I have a multisite with CustomPress plugin network installed.
When I activate the plugin, the subsites only have the two options under CustomPress: "settings" and "Export/Import" . There is no option for adding custom post types for that subsite.

I have tried Network Activating it. No custom adding.
I have tried Network Deactivated and individual subsite activation. Still no custom adding.

What am I doing wrong?

  • Tyler Postle

    Hey Paul,

    Hope you're doing well today!

    When menu items disappear like this it's almost always due to either:

    1. A permission issue. Likely not the issue here since it sounds like you are the super admin.

    2. Plugin conflict. Try deactivating all other plugins and see if that brings back the menus.

    If it's neither of those, then could you grant support access?

    You can grant support access via admin dashboard - WPMU DEV > Support > Support Access > Grant Access.

    We'll have to go in for a closer look :slight_smile:

    Look forward to hearing back!

    All the best,
    Tyler

  • Anang

    Hi @Paul

    Trying to help here :slight_smile:

    If you want to your subsite have their Custom Post Type settings, you must enabled it on Custom Press settings in Network. Go to Network Admin - CoursePress - Setting, check two checkboxes on "Enable sub-site content types".

    For now I have enabled this options and check on your subsites , there's one submenu "Content Types" to adding Custom Post Type :slight_smile: I attached screenshot to help you find the settings :slight_smile:

    Let me know if you have any questions :slight_smile:

    Best Regards

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.