CustomPress pagination not working

I am having a CustomPress pagination problems in page /catalog/. The /catalog/ is also saved as the "custom rewrite slug" in CTP settings. I am using a custom child theme and provided a zipped file in chat.

  • Predrag Dubajic
    • Support

    Hi Amir,

    Hope you're doing well :slight_smile:

    I did some extensive testing on my installation and I can replicate similar behaviour but I'm afraid that I'm not sure where the issue is so I will need to forward this to our developers for further investigation.

    Either me or one of my colleagues will notify you here when we have more info about this.

    EDIT: Can you try moving your query from page template to shortcode in your child theme functions.php and see if that works for you.
    So just move the query in functions.php and wrap it in shortcode function like this:

    add_shortcode( 'show_tombs', 'wpmudev_show_tomps_sc' );
    function wpmudev_show_tomps_sc( $atts ){
    //Your query here
    }

    After that create new page with default template and add this shortcode:
    [show_tombs]
    Let us know if pagination works in that case

    Best regards,
    Predrag

  • Ivan
    • Developer

    Hi amir levy !

    It seems it happens because you use catalog slug for this page and you set this slug for tomb Custom post type. You can check it here - WP Dashboard -> CustomPress -> Content Types -> Edit (tomb) -> Rewrite tab -> Custom Slug setting. Please, change one of them and it should work fine.

    Best regards,
    Ivan.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.