CustomPress styling on the front end

Hi guys!
Sorry, I don't see CustomPress in the drop down list.
I am having trouble styling the CustomPress plugin in the front end when using the [custom_fields_input] shortcode.
I've tried putting the shortcode in a responsive tab, box, and well (using other another shortcode/plugin) as well as trying it as a sidebar widget--but nothing seems to work. It puts the fields at 100% width no matter what. Am I missing something?
I also don't see Directory or Classifieds in the support list or the plugins list on the website. I hope this doesn't mean that the 3 of these plugins are going away too? I am relying heavily on these plugins :slight_frown:
Thanks for any help with this!!
hg

  • Adam Czajczyk
    • Support Gorilla

    Hello Hitt-Girl,

    I hope you're well today and thank you for your question!

    Both Classifieds and Directory plugin had been retired, I'm afraid. They are still available from our GitHub repository but are no longer maintained, developed and supported:

    https://premium.wpmudev.org/retiring-our-legacy-plugins/

    CustomPress is still here :slight_smile: I'm not however 100% sure what the issue exactly is. I understand that the "styling" of the shortcode in question doesn't work well for your site but I'd prefer to first see the site to be able to asses the case and propose a solution.

    That said, can you please point me to an URL where I could see that issue in action? Let me know where to find the area with shortcode in question added and how would you want it to look like and I'll then check it and do my best to help you out with this.

    Kind regards,
    Adam

  • Adam Czajczyk
    • Support Gorilla

    Hello Hitt-Girl!

    Thank you for granting access.

    I checked the site and while there was a shortcode from some other form used on this page, I temporarily replaced it with [custom_fields_input] shortcode (I already replaced it back) and I was able to see the issue.

    It seems like this is happening because the theme style defines some general rules for "input", "select" and "textarea" form fields that are interfering. It's not a big issue though, fortunately.

    When you put the [custom_fields_input] shortcode on a page, try adding this CSS to your site:

    .ct-form-field input, .ct-form-field select, .ct-form-field textarea {width:100%;}

    This should help, according to my browser-based test. To apply this code to your site either add it to the "style.css" of a child theme (if you are using a child theme) or to "Custom CSS" option of a theme (if there is such an option) or using Simple Custom CSS plugin.

    Best regards,
    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.