CustomPress Taxonomies "You do not have sufficient permissions to access this page"

Hi

I was having problems getting custom press to work, so decided to take some scree captures and load them on here. But when I went to edit my custom taxonomy, got the following message "You do not have sufficient permissions to access this page".

http://i85.photobucket.com/albums/k56/ardhill/NewDoNotHaveSufficentPermissions.png

I deleted the taxonomy, re-created and tried again - I still got the same message.

So, I installed a fresh version of wordpress 3.3.2, downloded a fresh copy of custom press 1.2.1.6 and created a brand new local WP multisite.
(Local development server - Desktop Server from Server Press)

The only plugins installed are custom press and your update notifications plugin 2.1.3 on a fresh install with default theme, no post or pages yet.

I went to custom press, created a new post type, then a new taxonomy. I tried to edit the taxonomy like before and still get the "You do not have sufficient permissions to access this page" screen.

http://i85.photobucket.com/albums/k56/ardhill/NewWordpressVersion.png

http://i85.photobucket.com/albums/k56/ardhill/NewPluginsInstalled.png

http://i85.photobucket.com/albums/k56/ardhill/NewTanonomyOverview.jpg

http://i85.photobucket.com/albums/k56/ardhill/NewCustomPostDetail.png

  • digitsoft

    This is actually a well known problem with WP and many plugins and there are a few things you can try. I've even tried these things and still had a problem, so post if you still do. Try these things one at a time....

    1. Get new salt keys and replace them in wp-config:
    https://api.wordpress.org/secret-key/1.1/salt/

    2. Save this as force-upgrade.php, save it where your wp-config.php file is, open in a browser, and then delete it:

    <?php
    /*
    WordPress Force Upgrade Script
    Copyright (C) 2006  Mark Jaquith
    
    This program is free software; you can redistribute it and/or
    modify it under the terms of the GNU General Public License
    as published by the Free Software Foundation; either version 2
    of the License, or (at your option) any later version.
    
    This program is distributed in the hope that it will be useful,
    but WITHOUT ANY WARRANTY; without even the implied warranty of
    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
    GNU General Public License for more details.
    
    You should have received a copy of the GNU General Public License
    along with this program; if not, write to the Free Software
    Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA  02110-1301, USA.
    */
    
    function txfx_log($text) {
    	echo $text . '<br />';
    }
    
    switch ($_GET['step']) :
    	case "1":
    		require('wp-config.php');
    		txfx_log('WordPress loaded...');
    		require('wp-admin/upgrade-functions.php');
    		txfx_log('Upgrade functions loaded...');
    		wp_cache_flush();
    		txfx_log('Object cache flushed...');
    		make_db_current();
    		txfx_log('Database made current...');
    		upgrade_160();
    		txfx_log('Data upgraded...');
    		$wp_rewrite->flush_rules();
    		txfx_log('Rewrite rules flushed...');
    		wp_cache_flush();
    		txfx_log('Object cache flushed...');
    		txfx_log('<br />');
    		txfx_log('Hopefully that did it!  <strong>DELETE THIS FILE FROM YOUR SERVER NOW!</strong>');
    		txfx_log('And then, try to access your <code>/wp-admin/</code>');
    		break;
    	default :
    		txfx_log('This script will attempt to upgrade your database.  It is intended for users of WordPress 1.5 or later.');
    		txfx_log('<strong>You should delete this script from your server after you are done using it!</strong>');
    		txfx_log('<br />');
    		txfx_log('<a href="?step=1">Click here</a> to attempt the upgrade');
    		break;
    endswitch;
    ?>

    3. Do you have a .htaccess file? If not, create one and put this in it:

    <IfModule mod_security.c>
    SecFilterInheritance Off
    </IfModule>

    If you already have one, rename it, and then create a new one with this code.

    4. Check ownership to ensure the current account owns all folders and files (chown)

  • Kimberly

    Ardhill,

    I'm not sure how CustomPress handles file permissions on a LocalHost, especially with the one you are noting. However it does seem that this is what is causing the issue. Somehow you cannot get back in to edit it.

    Are you running anything like ModSecurity?

    I'm attaching the live FTP version of checking your file permissions, and here is the codex list of file permissions http://codex.wordpress.org/Hardening_WordPress#File_permissions

    I was able to find some info via google about changing File Permissions locally, however I am not sure of your setup so I did not know what to recommend.

    Best,

    Kimberly

  • ardhill

    Hi digitsoft & KimberlyL

    Thank you both for your answers.

    I did all the items that digitsoft recommended, but still no sucess. Though both of you talked about permissions, and that is a sore point.

    My local machine is running on Windows 7 and file permissions are tricky. I set all the permissions to full access, but with no sucess.

    I am waiting on a domain name dns to point to my host and I will re-install a new 'hosted' version, and try again. At least I know that I am on a LAMP environment on that host.

    I will get back and let you know when I try again on the hosted domain.

    Thank You both for your time, trouble and help.

    Please take some"imaginary" rep points as I am stll building a few up before I can give them away.

    Paul

  • ardhill

    Just tried it.

    New domain, new hosted website, new install of WP multisite, only custompress and muwpdev updates plugins. All updated.

    Same problem - You do not have sufficient permissions.

    Filezilla and cPanel file manager are normally very good at setting the correct permissions automatically, but even so, after I got the "You Do Not Have..." message, I set the permissions of the custompress plugin folder to 775 and tried again - same problem.

    I set 775 recurrsive into all the files and folders - same problem :slight_frown:

    I don't think this plugin likes me :wink:

    Paul

  • ardhill

    OK, another attempt on my shared host.

    Another new domain name.
    Fresh install of WordPress (standard single site version)
    Fresh upload of CustomPress - now 1.2.1.7
    Upload of WPMUdev update notification

    The Taxonomy edit screen works, and lets me go back into a taxonomy I created.

    Now, disable plugins, and change the site to a multisite network.
    Enable plugins.

    Check CustomPress - I appear to have lost all my custom posts, taxonomy and fields.
    So, I create them again.

    And again, I cannot go back into the edit screen of the taxonomies after I created it. I get the message "You do not have sufficient permissions to access this page" again.

    So, it appears to work OK on WordPress single, but not multisite.

    Paul

  • Kimberly

    Paul,

    Sorry for the delay over the weekend, sometimes it's hard to get on during the weekend days :slight_smile:

    Now, disable plugins, and change the site to a multisite network.
    Enable plugins.

    Are you reinstalling CustomPress in the Network Admin and Network activating area before re-enabling?

    It may be an issue with the tables once they are created in a single site and then the database is changed to multisite.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.