Custompress template file creation problem

I tried creating my Custom post types successfully, but the problem is that the single-(custom post type).php file is not created, so I was not able to create a template on the page. I tried creating the file name through FTP but the problem is that I need the template file to put in the empty file I created.

What can I do next?

  • Timothy
    • Chief Pigeon

    Hey there.

    Are you doing this at the network level of the site level in multisite?

    I just tested on the network level and it created the file fine for me.

    Basically it takes your single.php of the theme you're using on the main site. It then copies to single-POSTTYPE.php

    If that file exists then the check button will be greyed out and selected so you can't change it. Is it still like that?

    Or can you create it again?

    If so then check the permissions on the theme folder to ensure it can be created.

    Failing that, you can simply copy the single.php and then rename it as needed. single-POSTTYPE.php

    Hope this helps.

    Take care.

  • Temylar
    • Design Lord, Child of Thor

    Thanks, I saw where the problem comes from I actually didn’t do it from the Network Admin area but on the dashboard of the main site, but in case I want to give my users the opportunity to actually use this where and how will they be able to get to create that file for them.

  • Timothy
    • Chief Pigeon

    Hey again.

    They are only available on the network level.

    If two people created the same post type the file could only be created once.

    If you had a plugin running which has it’s own post type then generating a new file just for the post type could overrule the template file originally handling it. Not always applicable but potentially causing issues.

    Code shouldn’t be accessible to the end users either as that poses a security issue so letting them generate a PHP file would only be replicating that of the single.php within a given theme. they couldn’t then edit it.

    So I’m not sure of the purpose of having this available to users within a network install?

    Hope this clarifies.

    Take care.

  • aristath
    • Recruit

    The original poster of this issue is no longer an active member on these forums.

    I am marking this issue as resolved.

    If however at some time the member becomes active again and the issue still exists, don’t hesitate to reopen it and post an update on your current status.



Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.