Dashboard did not update with en error

Hello
I had a problem with the dashboard update to 404.
Also at the last site (nedonrealestate.gr) it does not smush images (it remains at the gif animation forever)
I already enabled support access if needed.
Everything is running very slow.
I noticed I got some 403 errors at the log file during the upddate.

Please advise
Thanks
Mike

  • Kasia Swiderska
    • Support nomad

    Hello Mike,

    Access show up and works (one good news:slight_smile:. And smushing don't work - it throws some JS error, but I would like to see if there are errors on the PHP side. You said there were errors in debug log? Can you paste them here?

    Also - did you tried to exclude plugin conflict?

    kind regards,
    Kasia

  • Mike Papadopoulos
    • Flash Drive

    Hi Kasia
    Nice that some thing are starting to work.
    Through the erro log I see these:

    [22-Jan-2016 10:20:29 UTC] PHP Warning: in_array() expects parameter 2 to be array, string given in /home/XXXXXXX/public_html/wp-content/plugins/easy-property-listings/lib/widgets/widget-functions.php on line 783
    several (thousand) times and few times this:
    [22-Jan-2016 09:31:02 UTC] PHP Warning: call_user_func_array() expects parameter 1 to be a valid callback, function 'planify_customize_register' not found or invalid function name in /home/xxxxxxx/public_html/wp-includes/plugin.php on line 525

    While at the admin erro log I see these:

    [20-Jan-2016 10:25:21 UTC] WPMU DEV error: Upgrade failed - error 1
    [20-Jan-2016 10:25:21 UTC] [WPMU DEV Dashboard Info] Project Auto-Upgrade result for 119: Failed...
    [20-Jan-2016 10:25:22 UTC] [WPMUDEV Dashboard Error] HTTP Error: 403 "Forbidden"
    [22-Jan-2016 09:30:42 UTC] PHP Warning: call_user_func_array() expects parameter 1 to be a valid callback, function 'planify_customize_register' not found or invalid function name in /home/nedonrea/public_html/wp-includes/plugin.php on line 525

    [18-Jan-2016 12:54:40 UTC] PHP Warning: mysql_affected_rows(): 25 is not a valid MySQL-Link resource in /home/nedonrea/public_html/wp-includes/wp-db.php on line 1758
    [18-Jan-2016 13:18:16 UTC] PHP Warning: Invalid argument supplied for foreach() in /home/nedonrea/public_html/wp-content/plugins/sitepress-multilingual-cms/inc/wp-nav-menus/menus-sync.php on line 213
    [18-Jan-2016 13:19:05 UTC] PHP Warning: Cannot modify header information - headers already sent by (output started at /home/nedonrea/public_html/wp-content/plugins/sitepress-multilingual-cms/inc/wp-nav-menus/menus-sync.php:213) in /home/nedonrea/public_html/wp-includes/pluggable.php on line 1228
    [18-Jan-2016 12:54:40 UTC] PHP Warning: mysql_real_escape_string(): 25 is not a valid MySQL-Link resource in /home/nedonrea/public_html/wp-includes/wp-db.php on line 1129
    [18-Jan-2016 12:54:40 UTC] PHP Warning: mysql_errno(): 25 is not a valid MySQL-Link resource in /home/nedonrea/public_html/wp-includes/wp-db.php on line 1723
    [18-Jan-2016 12:54:40 UTC] PHP Warning: mysql_error(): 25 is not a valid MySQL-Link resource in /home/nedonrea/public_html/wp-includes/wp-db.php on line 1740

    I have pasted some here - most of them reappear several times.
    Hope this helps.

    Also: the backend is tragically slow.

    Thanks for the help, Mike

  • Mike Papadopoulos
    • Flash Drive

    Also my htaccess is very simple:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

  • Kasia Swiderska
    • Support nomad

    Hello Mike,

    Is this possible you could run quick test to exclude plugin/theme conflict? In your debug errors are coming from easy-property-listings, sitepress-multilingual-cms plugins and one is from your theme.
    To be sure we always ask to disable all other plugins including WPMU DEV and switch for while to default WordPress theme.

    kind regards,
    Kasia

  • Mike Papadopoulos
    • Flash Drive

    Hello guys
    I did something else: I made a backup of the site and restored it to a local installation (under ampps) and it did smush the images.
    But I noticed that I had WPML disabled and instead, I used Polylang (similar).
    I then enabled WPML and disabled Polylang.
    I could not smush any more, so the conflict is with WPML. (I beleive).

    Mike

  • Kasia Swiderska
    • Support nomad

    Hello Mike,

    That would be correct - if only difference was with this plugins, the we have a "winner". Can you tell me what WPML version you use and additional plugins for it (if you use any). I'll contact with WPML team to get copy of them and do more tests to see where lays problem.

    kind regards,
    Kasia

  • Kasia Swiderska
    • Support nomad

    Hello Mike,

    Could you do a staging copy of the client site and let us in through support access, so we could check again that issue? I would not like to test this on live site because I'll need to turn off and on plugins. Staging site can be on sub-directory of existing site, so we could also check is environment is not the issue here.

    kind regards,
    Kasia

  • Ash
    • WordPress Hacker

    Hello @Mike

    I hope you are doing good.

    Thanks for enabling support access, I have taken a closer look. There is an error in the console at wp-smushit-admin.js:266:

    Uncaught TypeError: Cannot read property 'error_msg' of undefined

    I have also noticed, during ajax request, there is no action attribute passed to the ajax handler, rather it passes a lang variable with value "en?action=wp_smushit_manual", clearly this is a conflict with your wpml. I am sending a note to the developer @Umesh Kumar about this issue, I believe he will reply as soon as possible.

    Have an awesome day!

    Cheers
    Ash

  • Kasia Swiderska
    • Support nomad

    Hello Mike,

    I've checked again WPML versions and from your dashboard looks like you have 3.3.5 - and I've checked that WP Smush Pro worked on my site with WPML 3.3.6.
    Can you update just to be sure? And also all additional WPML plugins like WPML CMS Nav and String Translation.

    kind regards,
    Kasia

  • Umesh Kumar
    • Code Wrangler

    Hi @Mike, @Ash,

    There was a small issue with WP Smush, the way it forms the URL in JS, I've temporarily fixed and uploaded a beta on the site.

    The fix will be included in next release, and automatically available in the update.

    For now, Smushing works absolutely fine on your site.

    Also, I've attached the working version of WP Smush Pro with the fix, in here. So that you can temporarily install this one on any other site, until the next release is available.

    Cheers, Umesh

  • ramirocastro
    • New Recruit

    Umesh, this is awesome, I've got a similar WPML-Smush pro conflict (at the beginning I thought it was the visual composer, as when disabled, I can smush again. Ultimately I also found that WPML CMS was conflicting with Smush Pro).

    See my thread with your colleague Tyler here: <a href="https://premium.wpmudev.org/forums/topic/smush-pro-213-does-not-work-with-visual-composer-492?replies=6#post-1033365
    ">https://premium.wpmudev.org/forums/topic/smush-pro-213-does-not-work-with-visual-composer-492?replies=6#post-1033365

    I installed this version you attached, and I don't have anymore this error below...

    ""Uncaught TypeError: Cannot read property 'error_msg' of undefined" for wp-smushit-admin.js line 266"

    ...in the console when trying to smush files. That was the error I got when I have WPML CMS active. Whatever you have done, it fixed the error with WPML CMS. Thanks!

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.