Dashboard Plugins DO NOT Install.

We have recently moved our hosting to a VPS system (Bluehost). After making this change, we are unable to install any WPMU DEV plugins via the Dashboard.

When we try to install we get an error that says "Install package not available". It doesn't matter which WPMU DEV plugin we try to install - the result is the same.

We are able to go directly to WPMU DEV and download the plugin then upload it as a ZIP and infall it manually. (SO while this is not a critical issue, it is a convenience issue.)

We're suspicious that our VPS may not have the necessary configuration in place to make this work - and - thus the error we are seeing and our inability to install any WPMU DEV plugins via the dashboard.

Any assistance/advise appreciated.

  • Vinod Dalvi
    • WP Unicorn

    Hi @Jeff,

    Sorry to hear of the problem you are having.

    Your web host may be restricting HTTP Requests to our server therefore may be your site can't communicate with premium.wpmudev.com or api.wpmudev.com.

    Could you please check and let me know what is the status of "Remote HTTP Requests" from the following path?

    Admin area -> WPMU Dev -> Support -> System Info

    If it not allowing Remote HTTP Requests then you'll need to ensure that fsockopen or cUrl are enabled on your server. These should be within the PHP configuration in your control panel. See this comment, it might help you configure with it:
    https://premium.wpmudev.org/forums/topic/mpmu-dev-dashboard-api-key-not-working#post-245649

    If you have any error_log entries related to these connections they could help in diagnostics so please share it to me.

    Kind Regards,
    Vinod Dlavi

  • Vinod Dalvi
    • WP Unicorn

    Hi @Jeff,

    Thank you for your reply.

    Would you mind if I logged in to your site and did some testing? This might help get to the bottom of this faster. If this is ok, just grant me temporary admin access to your site by clicking "Grant Access" button in the WPMU DEV Dashboard Settings from the following path and reply on this thread after granting it?

    Admin -> WPMU DEV -> Support -> Support Access Tab

    Regards,
    Vinod Dalvi

  • Vinod Dalvi
    • WP Unicorn

    Hi @Jeff,

    Thank you for granting me support access.

    I checked your site and found WPMU Dev themes are installing properly without any issue, the issue is in installing WPMU Dev plugins.

    Could you please check that the correct folder permissions are set in wp-content/plugins.

    That folder needs to be writable.

    Can you check the Varnish cache settings at your host?

    Regards,
    Vinod Dalvi

  • Jeff
    • Site Builder, Child of Zeus

    Hi Vinod,

    Thanks for your help. I have found the issue. I disabled all plugins (except the WPMU DEV plugins) and then tried installing WPMU Plugins while methodically re-activating the other 3rd party plugins until I found that the a plug-in named "MOJO Marketplace" ( a plugin that is automatically installed for Bluehost WP accounts) was the culprit.

    De-activating MOJO Marketplace resolves the issue. Fortunately MOJO Marketplace is not a plugin I need or want (I was planning to delete it anyway).

    Thanks for all your help - most appreciated, but it does appear to be a plugin conflict.

    -Jeff C

  • Vinod Dalvi
    • WP Unicorn

    Hi @Jeff,

    Awesome, great to see you got that resolved.

    I was going to tell you as a final step ( As most users can't deactivate plugin on their site ) to deactivate all other plugins and using default WordPress theme like Twenty Thirteen as displayed in the flowchart on the following page to know which theme/ plugin is conflicting if any.

    https://premium.wpmudev.org/manuals/getting-support/

    Thanks for taking a forward step to resolve the issue and posting the solution on thread, it will help other users facing the same issue.

    Thank you for being a WPMU DEV member and have a great day!

    Cheers,
    Vinod Dalvi

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.