Database error connection after activating Live Stream Widget Plugin

Hi,

My multisite is running supper slow after activating Live Stream Widget, Comment Indexer and Post Indexer. I can't event use the P3 scanner to verify which plugin is causing my site to crash. Can someone please help.

  • Michelle Shull

    Heya, Serge!

    I just took a look at your site in YSlow, and it looks like you've got a pretty big load, your site's total size is 3700k. Most of that is images, which means you can do a lot to improve your load time by using optimized images. Our SmushPro can help here, but the most effective way would be to make sure your original images are no bigger than they have to be, and to save them for the web, which will optimize the image to show at the highest quality with the lowest file size. You can save for web in both premium image editors like Photoshop, or in free alternatives, like Paint.net.

    You've got a big javascript load, too, there are 56 scripts loading every time your page loads. These come from plugins, and can be a necessary evil, but it may be worth auditing your existing plugins and breaking up with any you don't love and/or absolutely need.

    As for Post Indexer and Live Stream, both of these are pretty resource intensive. They need to be - scanning your network for new posts for the stream regularly is going to require resources, no matter how optimized a plugin is.

    Here's a great resource on optimizing your site, and I attached a screenshot of your site size breakdown from YSlow. https://premium.wpmudev.org/blog/clean-up-optimize-wordpress/

    Thanks, Serge!

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.