Database set up properly?? not able to get to dashboard page

I am having issues with my MS installation. The problem is weird and I believe created by my hosting company. I've never had any issues with my site (www.powermediallc.org) before, but last week my problems began...multiple problems but here is one.

Currently, all of my sites are functioning properly for a visitor. The problem lies when trying to login to the dashboard for all my sites. The login page appears, but never connects to the dashboard when entering username and password. Error message states that their are too many redirects. In looking at the wp-config file, my host directed it to a database that is not the one we set up for the multi-DB plugin. However, as I mentioned above, the sites still load for visitors, just not the admin section. Would anyone be able to help me/guide me through this so I don't have any downtime. I'm afraid to change the wp-config file for fear of screwing up all my sites.

Please help!

  • bdonaghy

    Hi Jack!

    Thanks for your quick response. Below is my .htaccess file.

    AddEncoding gzip gz
    <FilesMatch "\.gz$">
      ForceType text/plain
      Header set Content-Encoding: gzip
    </FilesMatch>
    
    RewriteEngine off
    # BEGIN WPSuperCache
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    #If you serve pages from behind a proxy you may want to change 'RewriteCond %{HTTPS} on' to something more sensible
    #AddDefaultCharset UTF-8
    #RewriteCond %{REQUEST_URI} !^.*[^/]$
    #RewriteCond %{REQUEST_URI} !^.*//.*$
    #RewriteCond %{REQUEST_METHOD} !POST
    #RewriteCond %{QUERY_STRING} !.*=.*
    #RewriteCond %{HTTP:Cookie} !^.*(comment_author_|wordpress_logged_in|wp-postpass_).*$
    #RewriteCond %{HTTP:X-Wap-Profile} !^[a-z0-9\"]+ [NC]
    #RewriteCond %{HTTP:Profile} !^[a-z0-9\"]+ [NC]
    #RewriteCond %{HTTP:Accept-Encoding} gzip
    #RewriteCond %{HTTPS} on
    #RewriteCond %{DOCUMENT_ROOT}/wp-content/cache/supercache/%{SERVER_NAME}/$1/index-https.html.gz -f
    #RewriteRule ^(.*) "/wp-content/cache/supercache/%{SERVER_NAME}/$1/index-https.html.gz" [L]
    
    #RewriteCond %{REQUEST_URI} !^.*[^/]$
    #RewriteCond %{REQUEST_URI} !^.*//.*$
    #RewriteCond %{REQUEST_METHOD} !POST
    #RewriteCond %{QUERY_STRING} !.*=.*
    #RewriteCond %{HTTP:Cookie} !^.*(comment_author_|wordpress_logged_in|wp-postpass_).*$
    #RewriteCond %{HTTP:X-Wap-Profile} !^[a-z0-9\"]+ [NC]
    #RewriteCond %{HTTP:Profile} !^[a-z0-9\"]+ [NC]
    #RewriteCond %{HTTP:Accept-Encoding} gzip
    #RewriteCond %{HTTPS} !on
    #RewriteCond %{DOCUMENT_ROOT}/wp-content/cache/supercache/%{SERVER_NAME}/$1/index.html.gz -f
    #RewriteRule ^(.*) "/wp-content/cache/supercache/%{SERVER_NAME}/$1/index.html.gz" [L]
    
    #RewriteCond %{REQUEST_URI} !^.*[^/]$
    #RewriteCond %{REQUEST_URI} !^.*//.*$
    #RewriteCond %{REQUEST_METHOD} !POST
    #RewriteCond %{QUERY_STRING} !.*=.*
    #RewriteCond %{HTTP:Cookie} !^.*(comment_author_|wordpress_logged_in|wp-postpass_).*$
    #RewriteCond %{HTTP:X-Wap-Profile} !^[a-z0-9\"]+ [NC]
    #RewriteCond %{HTTP:Profile} !^[a-z0-9\"]+ [NC]
    #RewriteCond %{HTTPS} on
    #RewriteCond %{DOCUMENT_ROOT}/wp-content/cache/supercache/%{SERVER_NAME}/$1/index-https.html -f
    #RewriteRule ^(.*) "/wp-content/cache/supercache/%{SERVER_NAME}/$1/index-https.html" [L]
    
    #RewriteCond %{REQUEST_URI} !^.*[^/]$
    #RewriteCond %{REQUEST_URI} !^.*//.*$
    #RewriteCond %{REQUEST_METHOD} !POST
    #RewriteCond %{QUERY_STRING} !.*=.*
    #RewriteCond %{HTTP:Cookie} !^.*(comment_author_|wordpress_logged_in|wp-postpass_).*$
    #RewriteCond %{HTTP:X-Wap-Profile} !^[a-z0-9\"]+ [NC]
    #RewriteCond %{HTTP:Profile} !^[a-z0-9\"]+ [NC]
    #RewriteCond %{HTTPS} !on
    #RewriteCond %{DOCUMENT_ROOT}/wp-content/cache/supercache/%{SERVER_NAME}/$1/index.html -f
    #RewriteRule ^(.*) "/wp-content/cache/supercache/%{SERVER_NAME}/$1/index.html" [L]
    #</IfModule>
    
    # END WPSuperCache
    
    # BEGIN WordPress
    #php_value memory_limit 768M
    
    #uploaded files
    RewriteRule ^(.*/)?files/$ index.php [L]
    RewriteCond %{REQUEST_URI} !.*files/curriculum.*
    RewriteCond %{REQUEST_URI} !.*wp-content/plugins.*
    RewriteRule ^(.*/)?files/(.*) wp-includes/ms-files.php?file=$2 [L]
    RewriteRule ^(.*/)?avatar/(.*) wp-content/avatar.php?file=$2 [L]
    RewriteRule ^(.*/)?sitemap.xml wp-content/sitemap.php [L]
    
    # add a trailing slash to /wp-admin
    #RewriteCond %{REQUEST_URI} ^.*/wp-admin$
    #RewriteRule ^(.+)$ $1/ [R=301,L]
    #RewriteRule ^(.*)[^/]$ $1/ [L,R=301]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule . - [L]
    RewriteRule  ^([_0-9a-zA-Z-]+/)?(wp-.*) $2 [L]
    RewriteRule  ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]
    
    <IfModule mod_security.c>
    <Files async-upload.php>
    SecFilterEngine Off
    SecFilterScanPOST Off
    </Files>
    </IfModule>
    
    <IfModule mod_deflate.c>
    <FilesMatch "\.(js|css)$">
    SetOutputFilter DEFLATE
    </FilesMatch>
    </IfModule>
    
    # END WordPress
    
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # uploaded files
    RewriteRule ^files/(.+) wp-includes/ms-files.php?file=$1 [L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule . index.php [L]
  • bdonaghy

    Just looking for a little assistance here. Right now all my Wordpress MS sites are functioning for visitors. The problem lies in the admin section. I cannot access the dashboard page. I believe the problem may be with the database, but I'm hesitant to make a change and bring down the sites.

    Here is some background information:

    The db-config.php file has the db listed as test_global. However the wp-config.php file has define('DB_NAME', 'testabc');

    Should they be the same? Would changing this cause any downtime for our sites?

    Thanks for any help you can provide.

  • Jack Kitterhing

    Hi there @bdonaghy

    I hope you are well today and sorry for the delay, would it be possible to disable wp super cache and roll back to a standard .htaccess file and see if the admin side then works? The default .htaccess files can be found here http://codex.wordpress.org/Multisite_Network_Administration

    Then with the DB, so your global DB is a different name to what you have defined in your config?

    Thank you!

    Kind Regards
    Jack.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.