Default/Paragraph ordering not working at all

Tried many many combinations, its ignoring any paragraph settings I give it! So far the only thing I can get to work is to use the Predifined Position - Halfway through your post. But then if I have a second ad, and say I want it two paragraphs down, it gets pushed all the way to the bottom. I am using shortcodes in my ads.

  • Ken Kimbrell
    • The Crimson Coder

    Hello Emily-

    Could you please provide the link where the issue is occurring? Is the problem on the Related Articles or Featured post? I noticed that you only have one shortcode in each Post Ad, does the problem happen when you have multiple shortcodes on one Post Ad?

    Let me know how I can help!

    Take Care,

    Ken - WPMU DEV Support

  • Ken Kimbrell
    • The Crimson Coder

    Hello Emily-

    Have you tried going into your text editor and wrapping each shortcode in a paragraph tag? For example:

    <p>[some_shortcode]</p>
    <p>[another_shortcode]</p>

    To separate the content more than a default paragraph separation, you can do two things.

    1. add < br > tags after each paragraph, one < br > skips down one line.

    2. add custom classes to one or all of the paragraph tags like this:

    <p class="custom_add_post">[some_shortcode]</p>
    <p>[another_shortcode]</p>

    Then style the top paragraph to create separation between the content. See code below:

    .custom_add_post{
    margin-bottom:50px; /***This will create a separation between the content ***/
    }

    You would need to apply the custom CSS to your child theme's style.css to prevent the custom style from being overwritten if you were to update your theme.

    Let me know how this works for you!

    Take Care,

    Ken - WPMU DEV Support

  • Emily
    • Flash Drive

    Hi there. I don't think you are understanding what the problem I have is. When I select the option Inject first Ad after this many paragraphs
    Your first Ad will be injected in your post after this many paragraphs.

    It literally places my ad (I am now only using one shortcode) at the top of the post. Its completely ignoring the setting altogether. The only way I can get it to place it is to use the Predefined Layout option of halfway through the post. I did try wrapping the shortcode in a para tag and it didn't do anything.

    See link to view the issue: http://awesomescreenshot.com/0426aa4c60
    Thanks!

  • Ken Kimbrell
    • The Crimson Coder

    Hello Emily-

    The screenshot you sent me, does not correlate with what I saw when I visited the site. It appears you may have re-positioned the author box in a different area? I will still look into the settings of paragraph placement not taking effect. I do apologize for the inconvenience. See image below of what I am currently seeing:

    Let me know how I can help!

    Take Care,

    Ken - WPMU DEV Support

  • Emily
    • Flash Drive

    I still have not gotten a resolution to this problem. If I place it using the positioning of after so many paragraphs it ads it into our author box at the top of the post. Do you need me to change the setting so you can see where it is placing it? I have unlocked support on the site, if you can login and take a look.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.