Defect with Revolution Slider…. professional help needed

Valued Support-Team,

last week we requested help for our Theme issue with Revolution Slider. Your colleague Michael was so kind to fix the problem (see attached screen shoot).

However just two days after that unfortunately we run into new troubles caused by the new m2PRO… since then we are still active just to recover those hazzles – instead of progressing with our application :slight_frown:

So, today we need to ask you once again please fix the revolution slider on our homepage.

We looked up the earlier problem solving solution (which were a piece of code in function.php file of our child theme)… implemented code is still there


does not work out. With other word we experience same problem as before on our homepage.

Many thanks upfront.



  • Tyler Postle
    • CGO

    Hey Prinz,

    Hope you’re doing well today!

    It looks like the images are still using the media protection url, and you currently have that add-on off in M2. Can you try removing and re-adding the slider images, this should give them the proper url :slight_smile: as right now it’s not finding the images.

    If that doesn’t work, can you temporarily swap to the default 2015 theme and confirm that the slider works there? Just so we know it is in-fact the theme again this time.

    Let us know and if you’re still not able to get this working we’ll have another look!



  • Klaus
    • The Crimson Coder

    Hello Tyler,

    frankly right now we are on our lowest point of desperation and we know as well what we would love to do everything in this world not to bother at all you, but we are absolutely overwhelmed, unable to jump out of this disaster.

    Yes – we easily can imagine how frustrating it must be getting so many support request from us… frankly and truly we wished that would not be the case at all. Unfortunately now, we got the impression you and your team misunderstand us entirely (probably one result of not being able to express like a pro also being unable to communicate proper in your mother tongue) when we with every support request repeat information (since/when a the issue turn up) from our point of view only meant as possible help as we don’t know upfront who of you guys is on duty… so we believe many information ease a problem.

    Yes – we assure you to 100% too – we are very sincere and seriously when we addressing you with valued team (in the truest sense of the word), and we strongly believe to give feedback is not only honest meant it’s also done with utmost respect… a little give back to express gratitude for help.

    That said, we are begging you please help us out in one go to avoid running in a next, and a next, and a next problem… asking for support over and over again (feeling always so sorry that we are no professionals like you) BUT we are struggling a lot simply because things don’t go better….

    If we would be able (please trust us we tried it seriously, before requesting help from you) to switch on Add-on from M2 we would do it and true is also, that we can’t get the PRO version installed. We already asked Sajid yesterday for help and do adjure he will help shortly…

    If we would be able to fix theme revolution slider by re-adding the sildes (please trust us, we tried it seriously) we would do it… but fact is we seriously need help.

    Unluckily that’s not all: The Avatar – which Jude once could solve so brilliantly – needs to be fixed again and we do hope (always with sincere respect to all you guys) this could be done also right now…

    And we do hope right now, that one of you kind guys can organize all those issues to get them all sorted out in order and deep hope that we don’t have to request any help at all.

    We plead this with most respect from the bottom of our heart.

    Thank you for your attention.



  • Michael Bissett
    • Recruit

    Hey @prinz,

    While I’m seeing that the Free version of Membership 2 is installed on your site (and not the Pro version), the issue turned out to be due to the Media Protection add-on inside of the plugin, I changed the setting for it to “Hybrid Protection”, and I’m seeing that the slider’s working as it should now. :slight_smile:

    Could you confirm this on your end please?


    Kind Regards,



    That said, we are begging you please help us out in one go to avoid running in a next, and a next, and a next problem… asking for support over and over again (feeling always so sorry that we are no professionals like you) BUT we are struggling a lot simply because things don’t go better….

    Trying to handle every issue in a single thread can really slow down the progress made on a thread, especially considering the sheer amount of issues we’ve come across with this site. We ask for a thread to cover 1, maybe 2 issue(s), because it allows us to assist you better, and provide you better support. :slight_smile:

    As to the Avatars issue, if you could provide a link to the thread where you opened this issue, please do, as trying to deal with multiple issues in a single thread, especially in a circumstance like this, can be very confusing.

    Us not being confused as to what’s going on in the thread helps us to give better support. :slight_smile:

    BUT we are struggling a lot simply because things don’t go better….

    Given the size of this project, here’s my honest, sincere, and well intentioned recommendation:

    1. Move to hosting more suitable for this prototype, we’ve got a handy article you can browse find some recommendations:

    Move over to the new hosting ASAP, don’t wait until the prototype’s finished to start moving, it seems like most of the problems you’ve been running into could be resolved by doing this.

    Trying to build a large Multisite on shared hosting already isn’t going to go well, and trying to set up a Multisite with Multi-DB on shared hosting really isn’t going to go well (a VPS is the minimum recommended type of hosting for Multi-DB).

    2. Hire a sysadmin (system administrator) to help manage this site, so that you’ll have a smooth, happy launch of the complete site (you’ll be so very glad you did this!). Who doesn’t like to be happy? :slight_smile:

    You’d be welcome to post on our Jobs Board:

  • Klaus
    • The Crimson Coder

    Hello Michael,

    thanks for your advice which we will follow shortly (we need job description for that).

    Meanwhile, we changed to Membership2 PRO see sceen shoot attached and we find out for sure activation of this plugin interfers media.

    Next we checked Media Protection… deactivated this Add-ON as frontpage Slides are not loading,

    see attached screen shoot.

    Please check it out again…. slides don’t work. Am sorry it needs to be fixed.



  • Klaus
    • The Crimson Coder

    Hi Michael,

    unfortunately as already reported with installing of m2 PRO version the backgrounds from revolution slider slides disappeared again.

    We strongly believe that should be the last time we are asking you kindly please, please fix it once more.

    Big thanks in advance .

    Support access is still granted.


  • Michelle Shull
    • DEV MAN’s Apprentice

    Hey there, Prinz!

    I’m stumped. Just to make sure another set of hands wouldn’t be the key, I just tried everything to get this to work for you.

    1. I made a new slider, no love.

    2. I replaced all the images in the original slider.

    3. I made a new slide.

    4. I turned of caching and tried all of that again.

    5. I tried all three image protection settings, as well as NO image protection settings.

    I’m either getting a 404 (not found) or 500 (internal server error) on your slides, depending on the setting. And it’s the entire slide, not just the images placed on each, that’s failing to load.

    While I was poking around, I did hit several database errors, if Michael is right above, and you’re on a shared host, I think that might be causing you more trouble than the savings it’s bringing you. You’ve got a really great network brewing here, it may be time to give it a little more room to breath on a dedicated server or VPN.

    As for the slider, I’m going to call in a bigger hammer (our friends in second level support) because I can’t figure out exactly where the dominoes are starting to fall here. From your description, it’s Membership2 and Rev Slider at odds here, let’s see if our second line guys can find out a more specific reason why they’re not playing well together.

    Thanks, as always, for your patience, Prinz!

  • Klaus
    • The Crimson Coder

    Hello Michelle,

    that’s really very kind off you jumping into this issue. I personally value your effort notably after a long workday very much… and yes, I also feel with you how frustrating it is, to get that slides in order again.

    It is so kind of you too, that you bring in the “big hammer” support… that means lots to us. Please let me repeat here what I already wrote to Michael:

    As mentioned in other posts our provider change is planned for early August. For that we will use the WPMU Job board, hopefully we place our vacancies adequate…

    However until then we have to finish anyhow this prototype. Unfortunately right now we’re under high pressure (missing all the lost time of this week) to get out site presentation done (especially the front page). On Monday 06/15/15 afternoon we’ve to conduct with important Philanthropist…

    Dear Michelle, do you believe you guys can fix our front page? It is for sure caused by m2 PRO as Michael has repaired twice those slides this week… our next step was then installing m2PRO when the slides crashed again. BTW m2 troubles obviously also other images we place in our pages… their are gone (but not a big deal to include them again). Of course estimate a time for searching and fixing a problem is quite challenging… sorry, but I have to ask upfront for the sake of that really important meeting which we can’t postpone. Please, dear Michelle, give me you opinion to that.

    Thanks so much for all!



  • Jude
    • DEV MAN

    Hey Prinz

    As I was looking through the site logs I could see your PHP is not setup correctly. There is a severe bug in (Library). See this for more info

    Dont be confused. The solution is to ask your webhost to run the commands listed there and fix the problem with PHP. You can use my screenshot to show them the results of the test along with your server logs



  • Klaus
    • The Crimson Coder

    Hello Jude,

    as suggested I contacted straight away provider… see entire chat script below. Provider states to fix .php.ini as explained below for both Revolution Slider issue AND db issue…

    PLEASE help…

    Looked up php.ini – it includes currently at the end of the file the following statements:




    2015-06-14 Bluehost Support

    There is a severe bug in (Library). See this for more info Please run the commands listed there and fix the problem with PHP.

    2:32:32am Prinz our site

    2:35:16am Josue your site just takes a long time to load

    2:37:08am Prinz am sorry but it does not load images and revolution slider

    2:39:42am Josue Is this a wordpress site?

    2:39:52am Prinz yes it is

    2:40:30am Josue Ok, well that command, won’t be able to be ran in the server, you don’t have root access

    2:40:42am Josue You need to configure whatever it is from the reveslider through the php.ini

    2:41:07am Prinz please can you tell me how to do that?

    2:41:47am Prinz mean what do I have to configure in php.ini

    2:44:15am Josue First you would have to generate the error

    2:44:16am Josue and I can

    2:44:24am Josue can’t seem to find anything related with what you stated Beate.

    2:45:03am Josue You are getting database issues

    2:45:05am Josue as well as php

    2:45:11am Josue that is related with your php.ini and your database.

    2:45:25am Josue

    [08-Jun-2015 20:06:57 America/Denver] PHP Warning:

    Unknown: Input variables exceeded 1000. To increase the limit change max_input_vars in php.ini. in Unknown on line 0

    [08-Jun-2015 20:12:59 America/Denver] PHP Warning: Unknown: Input variables exceeded 1000. To increase the limit change max_input_vars in php.ini. in Unknown on line 0

    [08-Jun-2015 20:27:40 America/Denver] PHP Warning: Unknown: Input variables exceeded 1000. To increase the limit change max_input_vars in php.ini. in Unknown on line 0

    [08-Jun-2015 20:32:12 America/Denver] PHP Warning: Unknown: Input variables exceeded 1000. To increase the limit change max_input_vars in php.ini. in Unknown on line 0

    2:45:32am Prinz please can you fix that

    2:45:39am Josue

    [25-Apr-2015 13:42:26 UTC] WordPress database error

    Unknown table ‘wp_iayq_27_leafletmapsmarker_layers’ for query DROP TABLE wp_iayq_27_leafletmapsmarker_layers made by require(‘wp-admin/plugins.php’:wink:, delete_plugins, uninstall_plugin, include(‘/plugins/leaflet-maps-marker/uninstall.php’:wink:, m_wpdb->query

    2:47:04am Josue This is not part of our scope of support Beate, you will need to contact a web developer

    2:47:11am Josue I would be more concerned with your database

    2:47:14am Josue it seems like its timing out

    2:48:53am Prinz what would be there the fix ? Please give a help

    2:51:01am Josue m_wpdb->query

    2:51:04am Josue that database is giving you issue

    2:51:16am Josue you need to increase your max imput limit for your php.ini

    Dear Jude, I hope that helps to get our issues solved. Looking forward hearing from you soon.


  • Adam Czajczyk
    • Support Gorilla

    Hello @prinz!

    I’ve read the entire thread here, conducted some research regarding Revolution Slider and payed special attention to @jude‘s advice and your conversation with your hosting’s tech support guy.

    What I’m about to say is not comforting, unfortunately. The commands that would fix the php issue mentioned by Jude can only be run either by you if you had a root access to your server (which you don’t, as far as I understand) or one of the server’s admins. The “tech guy” didn’t seem to be quite supportive here but the only way to run this fix would be to force them to do it. Or, which I guess is not an option here as previously discussed, switch servers…

    The other relatively quick workaround would be to replace Revolution Slider (which is know for causing various issues, btw) with another solution such as for example this one:

    I’ve never had any issue with it, though it’s always hard to say for sure unless you try it. I do realize that’s probably not an option here too but I’m not sure if there’s much else left to be done as well.

    Having said all that, I do sincerely apologize that I don’t have better answers for you yet. As @michelle has already called our 2nd-line support “big guys” and “wizards” for help, I hope they’ll be able to find a solution as soon as humanly possible.



  • Klaus
    • The Crimson Coder

    Hello Adam,

    frankly I can’t believe what I just read in your reply and frankly I can’t accept that either because (don’t ask me how it was done) JUDE were able to get both multi-db PLUS revolution slider PLUS many more very smoothly working.

    Exactly last Sunday we installed m2 PRO and had to cope the week with all that trouble this change caused.

    Also, Michael were able to fix twice Revolution Slider… please follow those conversation too.

    That it went from smoothly to worse and worst… SORRY this not our responsibility at all and we would not demand an immediate solution today if we would not know for 100% that you expert can fix it.

    Therefore PLEASE, PLEASE take utmost care and fix the problem to that person who is able to do it NOW.

    Thank You,



  • Jude
    • DEV MAN

    Hey Prinz

    I just made some changes to the config and now it all works (slider + multi DB etc ). Please don’t install more plugins as that only increases conflicts and load on the site.

    There was a conflict between something and the media addon of M2. So I turned it off

    Hope that helps


  • Jude
    • DEV MAN

    Hey Prinz

    Its working fine for me .. Rev Slider. See screenshots.

    It may sometimes not load because of the DB issue. But by itself it should work fine

    Also I made the changes in the php.ini file like the web host support guy suggested. It should be smoother now.



  • Klaus
    • The Crimson Coder

    Hello Jude,

    we haven’t been in the office the entire last week. Today I wish to express first our thank you about fixing our revolution slider.

    To update you the current status: Meanwhile the theme with revolution slider is working on our side to. The hassle was, that the background on the slides were missing… even if you could get it working on your system (as shown with above screenshots) on our end it didn’t work properly.

    We contacted themeforest they forwarded to us a theme update which we installed then. Since we the issue is solved.

    So it’s time to close this support request.

    Kind regards


Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.