Recent and previous versions of Defender adds 2 to 3 seconds on first byte.

I have avoided defender for several months because everytime I enable it and do setup ti adds 2 to 3 secs to first byte delivery. Disabling defender does not fix the problem. Deleting defender does not fix the problem. I thought it was other issues using AWS and massive images etc but after testing with bare wp 4.7 and seventeen theme it is very clear that defender or the config it create is the problem.

YOU can setup your own test and do not need to access anyone's system.
My current Test setup but it happened with earlier versions of php.
Apache 2, Proxy Nginx 1.11.4, PHp 7.1, FPM app served by Nginx
Fresh wp 4.7.1
Test 2 or 3 times with http://www.webpagetest.org/
Add wpmudev dashboard
add defender
run defender setup but DON'T follow any nginx rules the have not worked in the past for me. I ignore them they are protection not performance.
Test 2 or 3 times with http://www.webpagetest.org/

You can also use
https://testmysite.withgoogle.com/intl/en-gb/
https://premium.wpmudev.org/wp-checkup/

Then responded to this trouble ticket after you see results.

thank you

  • Rupok
    • Support Ninja

    Hi Lee,

    Thanks for asking. I've made three tests on my colleague Sajid's test site but I could not regenerate this issue. Please check the attached screenshot for reference.

    1. Before Installing Defender

    2. After Installing Defender

    3. After Configuring All Protection Rules in Defender

    In my test, first byte loading time was actually decreased after configuring all rules in Defender.

    Test server is using Apache with PHP 5.3.29 and WordPress 4.7.1.

    Please let us know what you think about this. I'm looking forward to hearing from you and resolving this issue as soon as possible.

    Have a nice day. Cheers!
    Rupok

  • Kasia Swiderska
    • Support nomad

    hello Lee,

    I have a site with PHP 7.1 and I did run again those tests:

    1. This is one with no plugins at all

    In case of the no plugins at all those values during tests were between 0.3 and 0.4 sec

    2. This is one with Defender enabled and hardening rules

    With Defender enabled values were always above 0.4 sec - but did not went up to be over 0.5

    3. Last test was with Defender and WPMU DEV enabled

    Again, those value does not go over 0.5 sec.

    I did test on PHP 7.0.14 and got similar results.

    I can't replicate increase of the first byte by 2 or 3 seconds.

    Can you now grant support access to site you were testing?
    To enable support access you can follow this guide here:
    http://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    kind regards,
    Kasia

  • Lee
    • Syntax Hero

    Well I thought I would try it again on an install that I was getting results: AAAAA Checkmark with webpagetest.

    Installed and network activated defender and my first byte went from uner .5 sec to 1.4 secs. Rerun test and got 1.6 and 1.7.
    That TTFB is a killer.
    results: FAAAA Checkmark

    All I did was activate it. I did not even go to the defender menus.

    Sorry but it is doing something that really causes my sites problems.

  • Nithin
    • Support Wizard

    Hi Lee,

    Hope you are doing good today. :slight_smile:

    Thank you sharing your observation, unfortunately I don't have a similar setup to extensively test this out, could you please send us the credentials of your test install so that we could have a better understanding of this, and if possible ping the developer regarding this, so that he could give a closer look at it, and see what's causing these delays.

    You can send credentials by using our secure contact form: https://premium.wpmudev.org/contact/#i-have-a-different-question

    - To Mark to my attention, the subject line should contain only: ATTN: Nithin Ramdas
    -WordPress admin username
    -WordPress admin password
    -login url
    -FTP credentials (host/username/password)
    -link back to this thread for reference
    -any other relevant urls

    Have a nice day. :slight_smile:

    Kind Regards,
    Nithin

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.