[Defender] Backups not happening as scheduled

Months ago, I scheduled backups to occur weekly for this website. However, none have been made. I've manually tried to back up the site from my "dashboard" that lists my 3 sites. This is my business website and I've already lost it once due to hackers. Why isn't it being backed up?

  • viobru
    • Support

    Hi, Marie!

    Thanks for contacting us, hope you are doing great :slight_smile:

    I’m sorry to hear that you are having issues with the backups of the site. Since the backups are created using Snapshot, I’ve changed the associated project to Snapshot since backups are created using it.

    To check what could be causing this, could you please share the following information with us via our secure contact form from this page?

    Subject: "Attn: Violeta" (Please use this subject line to ensure that it gets assigned to me :slight_smile: )
    - WordPress admin username
    - WordPress admin password
    - Login URL
    - cPanel credentials (username/password)
    - FTP credentials (host/username/password)
    - Linkback to this thread for reference
    - Any other relevant URLs

    Many thanks in advance!

    Kind regards,
    Violeta

  • viobru
    • Support

    Hi, Marie!

    Hope you are doing great and thanks for sharing the creds with us :slight_smile:

    I'm really sorry for the late reply here. I've been checking this and I noticed that there are a couple of things that could be related to Snapshot backups not being created successfully:

    1. The 3 sites are hosted on the same server on which the current PHP version is a very old one (5.4.45) and that could be related to Snapshot running slow on the sites. Please UPDATE the PHP version on the server, if possible to 7.x. This can be updated from your cPanel account under Software > PHP Selector:

    2. max_execution_time is currently set to 30 on o**************.n.com and on s**************h.com and Snapshot requires this value to be at least 150 to run properly (having this at minimum 150 is speacially necessary while processing all media files or creating a complete Snapshot or Managed Backup). Please, check this article about How to Increase the Maximum Upload and PHP Memory Limit and set the new max_execution_time value for the sites to at least 150 (max_execution_time is already set to 600 on s***************n.info, so it won't be necessary to change this on it).

    After applying these changes, please try running a complete snapshot on the sites and check the FULL LOG to see where does the snapshot fail if it is not created successfully, so you can inform us about it.

    Kind regards,
    Violeta

    NOTE: FYI, I was able to create a snapshot including ONLY the databases and wp-config.php and .htaccess files on s**************n.info and also on o****************n.com (please note that the snapshots I created DO NOT include ALL the media files). But I couldn't create it on s************h.com since Snapshot is not installed on the site, so you should INSTALL the plugin on it as well. Thanks.

  • Ari
    • Recruit

    Hey Marie

    Hope you are fine today!

    The issue maybe relate to disk space in your hosting, I can see this notice:

    There are lot of big files in the site like:

    I could replicate the issue in managed backup in your site with scheduled:

    So I think this issue is relate the disk space, so please increase the disk space by upgrading the plan or by removing some unnecessary files.

    After that if you still face this issue, let me know here!

    Best Regards,
    Ari

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.