defender breaks my site

Each time I have tried defender on any of the sites it breaks them. Changing the sql name is a total disaster. When it checks and finds things amiss and I delete them BAM there goe the site.

Is this plugin supposed to work ? or do you offer something else. I keep getting hacked that is the reason I decided to give wpmu a try but...

I cleaned out the server I was using at go daddy, started fresh files, bam hacked again. I tried a fresh install of wp and tried to use defender : this is what happened:
Error

A database query has failed. Is the entered database information correct? Does the account have available disk space?

type = mysql
host = localhost
database = i2896656_wp1
username = i2896656_wp1
password = **HIDDEN**

Technical information:
method = query

errstr = SELECT u.ID FROM wp_users u, wp_usermeta m WHERE u.ID=m.user_id AND m.meta_key='wp_user_level' AND m.meta_value=10 ORDER BY u.ID ASC LIMIT 1
MYSQL ERROR 1146: Table 'i2896656_wp1.wp_users' doesn't exist

    Adam Czajczyk

    Hello Bob,

    I hope you're well today and thank you for your question!

    The Defender plugin is working on many sites with no issues. It's worth to know however that there's always a chance that on some particular setups an unexpected problem may occur. That applies to our plugins as well to all other plugins around. There's so many combinations of WP versions + plugins' sets and configs + themes and servers around that it's virtually impossible to test "everything everywhere". That's why we are here so you could report such issues and we would then investigate in order to make it work.

    That being said, I understand that this only happens when you try changing DB prefix using Defender and changing it back makes the site work again. Is that correct?

    I've done that multiple times on my own sites so I won't be able to replicate the issue but most likely this is related to one of these two things: it's either your server setup that's built-in some additional security settings that prevent tables' prefix from being changed by WordPress or it's another (most likely security related) plugin that's interfering.

    That being said, let me know please if you are using any additional security plugins currently on your site and if so, what are those. Also, have you tried - just to test the issue - to disable all plugins but Defender and then execute that chagne?

    Finally, can you please tell me what is your current host? A link to a description of a hosting plan would also be very helpful.

    Please advise!

    Kind regards,
    Adam

    bob

    Well I deleted the site and moved to a new server.
    Installed fresh copy of wordpress.
    Installed WPMUDEV dashboard and Defender
    Issue found need to install htaccess did that now no access to site get a 404 error
    Did not change the data base name as that also breaks the site.
    Am I supposed to have some type of password or? I am about to give up.
    akismet and limit login attempts are the other security plugins.

    Adam Czajczyk

    Hello Bob!

    Thank you for your response and I'm really sorry about what's happening to your site.

    I've got a feeling though that I may be missing something here related to the issue. That shouldn't have happened and I know well of Defender running fine on all my test sites and hundreds of sites of WPMU DEV members. That must be something specific to your setup then or I must be missing something here.

    Having that said, I'm wondering about that part:

    Issue found need to install htaccess did that now no access to site get a 404 error

    Each WordPress install would have .htaccess file by default if the server is running on Apache web server. If it's running on nginx or some other web servers the .htaccess would not be there but on the other hand it shouldn't interfere. Could you then tell me please:

    - which of the Defender options requested you to "install .htaccess"?
    - what is the current content of the .htaccess file (please paste the content of it here so I could check it).

    Kind regards,
    Adam