[Defender] Defender doesn't let me access "/login" when login URL is masked

Whenever I enable Defender's Mask Login setting with any random slug, a page within my site with the slug "/login" becomes inaccessible. It says "This feature is disabled", even though the mask login URL slug doesn't have "login" in it.

We have tried a plugin/theme conflict test, enabling and disabling the setting and changing the mask login URL slug, but none of them helped. Debug.log doesn't show any relevant errors. Please advice.

  • David
    • Site Builder, Child of Zeus

    Hi, as I can remember that I have similar problems because of special characters in the slug.
    Please try slug without special characters just numbers and letters for the slug.
    Hope that solve your problem.
    Best regards.

  • Adam Czajczyk
    • Support Gorilla

    Hello Talal

    I hope you're well today and thank you for your question!

    I can see the /login page with the login form now so I believe that currently the login masking is disabled in Defender, correct? Still though, the regular /wp-login.php page cannot be accessed which means that a regular WP login is disabled as well.

    This would mean that the /login page acts as the main login form for your site right now and is either "overtaking" the regular login or there is some option (or other plugin) enabled that's doing that. Are you aware of any such option/plugin/code/setting on your site (apart from Defender's feature)?

    If that's the case, then the Defender's behavior would be logical as it's goal is to mask the main login area - the default one. There shouldn't be more than one "tool" changing that so while nothing stands in a way to have more than one front-end login form, none of these forms should at the same time block/restrict the default WP /wp-login.php form as otherwise it might lead to conflicts.

    Please note: since we don't have an access to your site at this moment, I can't fully verify if this is indeed the case on your site but that would explain what's happening.

    If you got any kind of option that already disables/restricts the default WP login, try disabling it before enabling login masking in Defender and see if that helps.

    If you can't find such option, please try temporarily disable Gravity Forms entirely and see if after that the /login page loads fine (it should load but just with shortcode displayed on it) if the masking is enabled in Defender.

    Let me know, please.

    Kind regards,

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.