[Defender] Defender: Manage Login Duration affects wp-cron operation

I noticed that as of October 16 2018, the wp-cron jobs on my site was failing.

Tests today indicated that the wp-cron tests for wp-cron.php Loopbacks was failing with a "Session expired, please login to continue" message.

After some testing, I found that reverting the setting for "Manage Login Duration" to the default WordPress setting resolved the problem.

I really would like to limit the amount of time someone can stay logged into the site but having scheduled tasks run is more important. Is there a setting I've missed somewhere?

  • Charly
    • Flash Drive

    Hi.
    Access is granted. Please note that I have reverted the changes so that my cron jobs run.

    To test:
    1. I noticed my backup buddy backups weren't running and I also noticed that a cron job I have setup to modify my_cred balances wasn't triggering (not related to Backup Buddy at all).

    2. I used the Backup Buddy Server Tools to find that wp-cron.php Loopbacks was disabled. Reading the return results from that test told me that the test was being presented with the 'please re login' message.

    3. I reverted the changes on Defender for Manage Login Duration and tested again. wp-cron.php Loopbacks were enabled and all the cron jobs on the site ran. I also ran a manual full backup to be certain.

    4. I reenabled Manage Login Duration. wp-cron.php Loopbacks were disabled, the message was in the return code, my cron jobs didn't trigger and a manual full backup was stuck waiting for a response.

    5. Reverting the changes fixed the problems again.

  • Kasia Swiderska
    • Support nomad

    Hello Charly,

    I'm sorry for the delay - I have spoken with our developers and they said that Manage Login Duration should not affect WP Cron. I also tested on my site with this test https://wordpress.org/plugins/wp-cron-status-checker/ and it didn't show any issues with Login Duration.

    But if you tested this couple of time on your site and it's clearly affecting - I'm thinking that maybe it's something specific to BackupBuddy not working with Login Duration. This is paid plugin so I don't have access to it for more thorough testing.

    Is it possible we could take a look on your site? Could you send us your details using our contact form https://premium.wpmudev.org/contact/#i-have-a-different-question and the template below:

    Subject: "Attn: Kasia Swiderska"
    - Site login URL
    - WordPress admin username
    - WordPress admin password
    - FTP credentials (host/username/password)
    - Folder path to site in question
    - Link back to this thread for reference
    - Any other relevant urls/info

    IMPORTANT: Please make sure you select "I have a different question" for your topic, so it doesn't go back to the forums - this and the subject line ensure that it gets assigned to me.

    Please confirm here that you send those credentials

    kind regards,
    Kasia

  • Kasia Swiderska
    • Support nomad

    Hello Charly,

    Thank you for sending me the access - I have "borrowed" BackupBuddy to test it on my site with Defender, but I wasn't able to replicate this issue which is happening on your site.

    I am going to escalate this to our Second Line Support Developers so they can investigate this problem on your site and see how can this be fixed.
    They will update you about results of their investigation in this ticket.

    kind regards,
    Kasia

  • Charly
    • Flash Drive

    Hi, I've been doing some more testing on this and narrowing the issue down.

    The problem appears to be between WP-Defender and Awesome Support.
    If I have WP Defender-Pro installed, with Manage Login Duration set to 7 days, my Backup Buddy backups fail. The testing shows that the wp-cron.php Loopbacks are failing.

    If I disable Manage Login Duration, the backups and my other Cron jobs run just fine.

    To test this, I disable ALL plugins except Awesome Support, WP-Defender Pro, WPMUDev Dashboard and Backup Buddy and can replicate the problem.

    I have a test site setup where this can all be tested without affecting the live site, if you would like the details sent through.

  • Patrick Freitas
    • Staff

    Hi Charly

    How are you today?

    Thank you for the update, I will update the Second Line Support about this. Can you please, send me the credentials for site test on our contact form?

    Note: Don't leave your login details in this ticket.

    Instead, you can send us your details using our contact form https://premium.wpmudev.org/contact/#i-have-a-different-question:

    Subject: "Attn: Patrick Freitas"

    - Site login URL:

    - WordPress admin username:
    - WordPress admin password:

    - FTP/SFTP credentials

    Host:
    Username:
    Password:
    Port:

    - cPanel credentials

    Host:
    Username:
    Password:

    - Folder path to the site in question:

    - Link back to this thread for reference

    - Any other relevant URLs/info:

    Please, reply to the ticket once you have sent the information.
    Best Regards
    Patrick Freitas

  • Rupok
    • Support Ninja

    Hi Charly,

    I'm so sorry for the time it's taking. I just checked the status and found that our second level support experts are still working on this. I believe they will come up with a fix very soon. We will update you here as soon as we get anything from them. I really appreciate your patience.

    Regards,
    Rupok

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.