[Defender] Defender plugin being replaced with another one

Hi,

Today I logged in to one of my clients` websites to find a very weird issue. The WPMU DEV defender plugin had been deactivated, deleted and replaced by this plugin: https://wordpress.org/plugins/wp-defender/

I had two-factor authentication setup and masked the login directory. I am also the only person who has access to the websites and to the control panel of the hosting account.

Has this happened to anybody else?

It doesn`t make ANY sense. I am only using the DIVI theme and WPMU DEV plugins. I am not sure where to go from here. I am happy to provide you with more information

  • Adam Czajczyk
    • Support Gorilla

    Hi Antonio

    I hope you’re well today and thank you for your question!

    There’s indeed an issue related to this. The “mess” happened on the wp.org plugin repository end and we’re trying to sort that out currently.

    However, were you running the free version of our Defender before the switch happened? By “free” I mean that the “WPMU DEV Dashboard” plugin was not enabled on the site? I’m asking about this because for such switch to happen the Defender would have to be in “free” version (so update would be fetched from the WP plugin repository instead of our site) and there would have to be either an update performed or an install via “Plugins -> Add new” page instead of “WPMU DEV -> Plugins”.

    Let me know please.

    Meanwhile, re-installing Defender via “WPMU DEV -> Plugins” should help until we’ll get the situation with WP plugin repository sorted out.

    Kind regards,

    Adam

  • Antonio
    • Flash Drive

    Hi Adam,

    Thank you for the quick reply.

    I am a bit relieved as I thought that there was a security breach and was frantically trying to ‘sort’ it out.

    Actually, I am never using the free versions of the WPMU dev plugins. What I usually do is to install the WPMU dev dashboard and then install all the plugins from it.

    Even though I reinstalled it, the issue occurred again, so my decision was to delete it for the time being.

    However, it doesn’t end here. The Smartcrawl plugin experienced the same problems. I had something else installed… do not remember the name now.

    I am not sure what is happening but I cannot use the plugins, even though I am paying for them at the moment.

    When is that issue supposed to be sorted out?

    Kind Regards,

    Antonio.

  • Adam Czajczyk
    • Support Gorilla

    Hello Antonio

    Thank you for your response!

    Yes, I realize that’s a real bummer. Fortunately, it’s not that the site – or the plugin – got compromised but the situation is of course not acceptable and should never happen. I’m not sure about when this might be sorted out as it involves 3rd-parties but I can honestly say that we’re doing everything that we can to handle that as soon as possible.

    I’m wondering about the SmartCrawl though. As opposed to Defender, I never heard of the case before. Do you recall what that plugin that replaced that could actually be? We might nee d to check that as well!

    Kind regards,

    Adam

    • Adam Czajczyk
      • Support Gorilla

      Hi Noavd

      I’m sorry to hear that. We’re still working on sorting that issue for good.

      However, could you tell me please: when it happened again was the WPMU DEV Dashboard active and was there any update on the site peformed? By “any update” I mean mostly any kind of “bulk” update, especially either via “Dashboard -> Updates” in site’s back-end or any (including even our Automate) external “automation” tool (or e.g. host)?

      Best regards,

      Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.