Defender plugin gives me a white screen!

Hi.

I have tried quite a few times in the past to load fender to http://www.web-me.at!

It always gives me a 'white screen'!

I tried again today. Same outcome!

Deleted it via server control panel.

I learned a little while ago (from a support ticket with yourselves) that my 'Theme Header' does not "conform to current protocols!!!

So today I am wondering if this may be the reason!

Any ideas, please?

Regards

John

  • Ash

    Hello john

    Would you please enable debug mode and check if there is any error? To enable debug mode please go to wp-config.php and change

    define( 'WP_DEBUG', false );

    to

    define( 'WP_DEBUG', true );
    define( 'WP_DEBUG_DISPLAY', false );
    define( 'WP_DEBUG_LOG', true );

    Now activate defender again. That will create a file called debug.log inside wp-content folder. Open that file, check the very bottom and you will see the latest errors. Please send me those.

    Have a nice day!

    Cheers,
    Ash

  • Adam Czajczyk

    Hello john,

    I hope you're well today and thank you for your question!

    The "white screen of death" is usually caused by either insufficient WP memory limit or some conflict of the plugins. There might be different reasons but these are the most common. I'd start with the memory limit then. Assuming that you have Defender not installed or disabled currently, please do as follows:

    - go to the "WPMU DEV -> Support" page in your site's back-end
    - click on "System Info" button
    - in a "PHP" tab look for the value of "memory_limit".

    In the next steps, if this value is anything below 256M, note it down and you'll use it; if it's 256M or more, we'll use 256M.

    - access your WP install via FTP or cPanel File Manager
    - open "wp-config.php" file for editing
    - add following line to the "wp-config.php" file above the /* That's all, stop editing */ line

    define('WP_MEMORY_LIMIT', '256M');

    If the value of "memory_limit" (as described earlier) is less than 256M, use that value here instead of 256M.

    - save the file on server

    Then try enabling Defender again. If it still doesn't work, that would mean a plugin conflict so disable it manually again - like you already did before - then access the site and disable all the plugins. Then enable Defender back and see if the site works. If yes, start enabling plugins one by one until the white screen happens again. The last one enabled would be the most probable source of the conflict so let me know what it was, please, and I'll then decide on what steps shoudl be taken next.

    Best regards,
    Adam

  • john

    Hi Adam & Ash.

    Did everything both of you said.

    Still got the white screen!!!!

    Here is the last partof the 'debug file':-

    [09-Mar-2018 12:56:53] PHP Notice: is_page was called incorrectly. Conditional query tags do not work before the query is run. Before then, they always return false. Please see Debugging in WordPress for more information. (This message was added in version 3.1.0.) in /var/www/vhosts/web-me.at/httpdocs/wp-includes/functions.php on line 4147
    [09-Mar-2018 12:56:53] PHP Notice: Trying to get property of non-object in /var/www/vhosts/web-me.at/httpdocs/wp-includes/query.php on line 781
    [09-Mar-2018 12:56:53] PHP Notice: add_custom_background is deprecated since version 3.4.0! Use add_theme_support( 'custom-background', $args ) instead. in /var/www/vhosts/web-me.at/httpdocs/wp-includes/functions.php on line 3839
    [09-Mar-2018 12:56:53] PHP Notice: The called constructor method for WP_Widget in ninosocial_widget is deprecated since version 4.3.0! Use

    __construct()
    instead. in /var/www/vhosts/web-me.at/httpdocs/wp-includes/functions.php on line 3902
    [09-Mar-2018 12:56:53] PHP Fatal error: Class '\Hammer\Caching\Behavior\Serialize_Behavior' not found in /var/www/vhosts/web-me.at/httpdocs/wp-content/plugins/wp-defender/vendor/hammer/base/component.php on line 241

    Regards

    John

  • Adam Czajczyk

    Hi @johnvocehome!

    I was hoping for a bit more specific number :slight_smile: Usually it's like e.g. PHP 5.4.2 or PHP 7.0.1 and so on. There are differences between these "sub-versions".

    However, most likely this is actually an issue. If it's anything below 5.6 some other our plugins might also cause issues but also a lot of 3rd party plugins may be troublesome. I'd definitely recommend switching to 7.x (preferably 7.1.x) version and I think that should also fix the Defender "white screen" problem.

    Usually, PHP version can be switched via server management panel (such as e.g. cPanel or WHM) so take a look there and see if you can do it. Just note please: sometimes the change might take a while (usually up to 15-30 minutes to be applied).

    Let me know if that helped, please!

    Best regards,
    Adam

  • Adam Czajczyk

    Ho @johnvocehome!

    That's a long run, indeed. But let's keep this ticket open for now just to make 100% sure that the switch works. I'd rather prefer to have it confirmed by you so I was sure that it's all fine :slight_smile:

    So, if it that switch works for you simply let me know here or just ignore that ticket and that's fine as well. But if you come back and let me know that even after the PHP upgrade it's still not working, I'll be ready to jump back and investigate that further :slight_smile:

    Best regards,
    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.