[Defender] Defender Scans and Divi Theme

For months now all of our Defender scans come back with an XSS vulnerability in Divi that was fixed since version 3.17.3.

The peculiar thing is that the current version of Divi (even stated in the Defender scan report email) is 3.19.4 which is well past the fixed vulnerable version so long ago.

I remember this happening in the past where the vulnerability in Divi was fixed in a much older version than the newest version of Divi that is installed and recognized by Defender...which even states so.

Is Defender having issues comprehending version numbers?