Defender doesn't delete plugin

Hi!

I have installed Defender plugin and run a scan. It has found two "suspicious" files, one of them is an error log and other - a file from EWWW image optimizer plugin.
I have masked an error log to be ignored and now - i want to delete the "suspicious" plugin. Well, let's help eliminate Hummingbird's competitors.

And, after i choose "delete the plugin" - nothing happens for about 10 minutes. For the third time i try to do that.

Of course, i can delete the plugin manually, but - no, i want to use the magnificent Defender feature.

  • Adam Czajczyk

    Hello Andrew,

    I hope you're well today and thank you for your question!

    I've tested deleting plugins with Defender on my test setup now and I was able to remove them. I then tried that on your end and I noticed an Internal Server Error 500 when trying to delete file. The error is related to admin-ajax call.

    Could you please try disabling the "Prevent PHP Execution" option temporarily in "Defender -> Hardener" settings and then give it another try?

    If that doesn't help, please:

    - access the site using FTP (or cPanel's "File Manager" tool) and check permissions for the "/wp-content/plugins" folder and folders inside; if the numbers are lower than 0755 try setting them to 0755 and give it another go

    Let me know about results, please.

    Kind regards,
    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.