[Defender] Getting "server rejected file" type errors uploading csvs when Devender active

Hi,
I was getting cryptic "server rejected file" uploading a csv for import (using wp all import pro), but it said just check server logs. Did not say what the problem was. Digging through the logs I just saw Defender error logs, so I disabled Defender and the file uploaded fine.. It looks like Defender may be conflicting with uploading files for import. Can you let me know how to disable that part? I won't always know what the file name is that is being imported. Thank you!

  • James Morris
    • WordPress Enthusiast

    Hello Aurelio

    I hope you are well today.

    I'm afraid I wasn't able to replicate this symptom on a fresh install of WordPress having only WPMU DEV Dashboard, Defender Pro and WP All Import installed and active. I was able to successfully upload and import a CSV file without issue.

    In order to help you better with your issue, would you please grant me access to your site and provide me with a sample CSV file that you're trying to import?

    You can learn how to grant WPMU DEV Support Access at the following link:

    https://premium.wpmudev.org/docs/getting-started/getting-support/#chapter-5

    Please reply back here once you've enabled access so I will be notified.

    Best regards,

    James Morris

  • Aurelio
    • Site Builder, Child of Zeus

    Hi James,
    I activated support access. This site has quite a few plugins, and is not a fresh install. I am using WP-All Import to transfer custom post type data for WP Types and Advanced Custom Fields. Things seem to work fine when Defender is off though. When Defender is on, I get "page not found" between some steps, but if I refresh, eventually I can sometimes get the import through. When Defender is deactivated, the steps just go through like normal.
    I uploaded screen shots of the steps I am following, as well as the latest file for import/integration. Thank you for any advice or help!
    Aurelio

  • Ash
    • WordPress Hacker

    Hello Aurelio

    We have sent your issue to our second level support team. Please note that, they deal with more complex issues, so there might be little delay. We appreciate your patience on this.

    Would you please send me your admin login and cPanel details?

    You can send me privately in the following format:
    1. Please go to https://premium.wpmudev.org/contact/#i-have-a-different-question
    2. Select "I have a different question" if not selected
    3. In subject line put "Attn-Ash" (this will ensure that the email is assigned to me)
    4. Provide the wanted details.
    5. Add the thread link in the message so that I can track.

    Have a nice day!

    Cheers,
    Ash

  • Aurelio
    • Site Builder, Child of Zeus

    Hi Ash,
    It seems to be working now.. I re-enabled Defender and got through the import fine without the above error happening.. Does that make sense? Would it be some weird server resource error that was happening, to cause the error I posted?
    Thank you.

  • James Morris
    • WordPress Enthusiast

    Hello Aurelio

    Seems a bit strange and worth monitoring but perhaps some issues with mime type support on the server could have caused this. Feel free to mark this issue as resolved for now, if you like, but if the issue resurfaces, please do re-open this task and we will be more than happy to dig into this issue further for you! :slight_smile:

    Best regards,

    James Morris

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.