Defender is reporting my site is down

Hi guys,

I recently installed an SSL on my website and now defender is reporting my website is down when it is in fact up as I can view it in my browser. Could this be due to the http(s)? If so, how can I fix it?

Thanks

  • Predrag Dubajic

    Hey Mike,

    Hope you're doing well today :slight_smile:

    Have you tried simply disabling and then re-enabling blacklist monitor after SSL changes?

    I tried checking this on your site but support access is unfortunately not working, do you have any additional security plugins or rules that might be blocking me from using support access?
    If you do could you temporary disable them so we can check this out?

    Best regards,
    Predrag

  • Dimitris

    Hey there Mike,

    hope you're doing good and don't mind chiming in! :slight_smile:

    It seems to me that there's something wrong with your setup. Even though the front end view is under a www subdomain address, like https://www.your_domain.com, the admin pages are under a non-www address like https://your_domain.com, which causes some errors and it may be the reason for HummingBird Uptime disconnection issue.

    Is there anything that you have made previously to get this non-www admin pages?
    Any rules in .htaccess file? Please advise!

    Also keep in mind the following article as I can see that you're using CDN to serve your assets.
    In this example, MaxCDN settings should have the proper site address.
    http://crunchify.com/how-to-fix-access-control-allow-origin-issue-for-your-https-enabled-wordpress-site-and-maxcdn/

    Warm regards,
    Dimitris

    • Baldafrican

      Hi Dimitris ,

      I don't mind AT ALL you chiming in as I would love this to be resolved :slight_smile:

      I had issues where my site was giving redirection issues after the SSL was installed. My host worked with me to get it back online unfortunately in my glee seeing it work again I did not look at the details.

      I would like this site to be served by the sitename without the www which is what my .htaccess file is doing. I am however a little limited in my skillset to know where else to change the urls to reflect this. So any advice is welcome.

      As for the assets; since the redirection was sorted, my Divi page builder no longer works. It just keeps loading but does not actually load. I have contacted Elegant themes and am still waiting on their response. Added to that I am using the delicious brains S3 plugin which sends my image to Amazon when I upload it. I too am not sure how to edit the 'local' url to reflect the new http(s) so instead I directed them to the S3 url. I know this is not your issue but if you have advice on how to solve this too, I am all ears :slight_smile:

      Thanks :slight_smile:

  • Dimitris

    Hi Mike,

    I would like this site to be served by the sitename without the www which is what my .htaccess file is doing. I am however a little limited in my skillset to know where else to change the urls to reflect this. So any advice is welcome.

    This should be handled by WordPress itself instead of using a redirection control via .htaccess file (even though it may helps to redirect non secure links).
    What has to be done, is actually to change the "siteurl" and "home" values to contain a secured non-www link. For that, you should follow the same workaround like if you were changing the domain name.
    Here you can find a detailed post on how to proceed https://wpengine.com/support/how-to-change-a-multi-site-primary-domain/
    If you don't want to mess with phpmyadmin or another DB client, you can use the famous Search & Replace for Multisite script that can be found here (including instructions to setup)
    https://interconnectit.com/products/search-and-replace-for-wordpress-databases/
    This is a solution outside the scope of WP plugins, and you can use this to search for "www.your_domain_name.com" and replace with "your_domain_name.com". It also provides a "dry run" to test how many changes a search&replace action will trigger.
    Please keep in mind to backup everything before proceeding, especially the DB. Snapshot can help you out with that. :wink:

    As for the assets; since the redirection was sorted, my Divi page builder no longer works. It just keeps loading but does not actually load. I have contacted Elegant themes and am still waiting on their response. Added to that I am using the delicious brains S3 plugin which sends my image to Amazon when I upload it. I too am not sure how to edit the 'local' url to reflect the new http(s) so instead I directed them to the S3 url. I know this is not your issue but if you have advice on how to solve this too, I am all ears

    After setting up the certificate, you should use a plugin like the followings, which allow your assets to be served from secured (https://) links instead.
    https://wordpress.org/plugins/really-simple-ssl/
    https://wordpress.org/plugins/wp-force-ssl/
    This will ensure that you don't have any kind of mixed-content errors, meaning that your https:// site won't try to load assets from http:// sources. I presume that this was the error that was breaking Divi builder but can't be sure if I don't see the actual broken state.

    As for the S3 usage, if you set anywhere in its settings, the origin domain of your setup, then use the secured non-www version of it, after you've sorted out the non-www issue.

    Warm regards,
    Dimitris

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.