Defender keeps locking me out despite white lists

For some reason I keep getting locked out of the site by Defender, I tried accessing it from another computer at another location and I still have the same problem. I know for fact that my one IP is in the White list for both 404 and login lock out. Is there another way to unblock my self? So far I tried renaming the plugin folder but that didnt do it.

  • Sajid
    • DEV MAN’s Sidekick

    Hello GMCS,
    Hope you are doing good today :slight_smile:

    I am glad to know you have figured it out. Please note that, it is better to fix 404 errors (mostly images) on a page to avoid any un-necessary lockouts for your visitors.

    Take care and have a nice weekend :slight_smile:

    Best Regards,
    Sajid - WPMU DEV Support

  • GMCS
    • WPMU DEV Initiate

    So I thought I figured out what the problem was but I continued to get locked so I contacted our hosting tech support and here is what they replied. I undertand what's going on but how can I continue to use Defender without constantly getting locked out of the site, no tu mention that visitors are experiencing the same issue.

    Thank you for contacting us.

    Allow me to explain the situation.

    Since you are using CloudFlare the IP address is routed via the CDN, therefore for all the login attempts you see the CloudFlare IP address.

    If you disable CloudFlare you will start seeing the real IP addresses.

    I recommend you installing a strong Captcha plugin on the login screen, and therefore avoid further troubles with the login attempts.

    And if further issues occur, do not hesitate to contact us again.

    Best Regards,
    Georgi Vichev
    Technical Support Team

  • GMCS
    • WPMU DEV Initiate

    Attaching some of the Defender logs, so if I understand correctly what our hosting support said is that CloudFlare is masking the source IP attempting to login and since Defender only sees the CloudFlare IP, that is what it is blocking, therefore completely blocking access to the site as Defender effectively blocks ClodFlare.

  • Denitsa
    • WordPress Warrior

    Hey there GMCS,
    I hope you're well! :slight_smile:

    What you could do is whitelist Cloudflare's IP addresses in Defender. You can find a list of those here: https://www.cloudflare.com/ips/ It's a recommended step when setting up CloudFlare (see those steps here https://support.cloudflare.com/hc/en-us/articles/201897700-Step-4-Recommended-First-Steps-for-all-Cloudflare-users)

    You can use this CloudFlare plugin: https://wordpress.org/plugins/cloudflare/
    It should restore the original visitor IP, or you can try installing the Mod_Cloudflare (more info here https://www.cloudflare.com/technical-resources/#mod_cloudflare) to do the job.

    Let me know how it goes!

    Cheers,
    Denitsa

  • Sean
    • New Recruit

    Hello, we are seeing the message for a blocked ip from wp defender on homepage only which effectively prevents all users from logging in unless they remember the url for the my acct page. Based on comments above, it's possible there could be a 404 issue. I think this could have been due a slider we had been working on with some internal link/buttons. I have removed the slider and posted one that works and still getting the same issue. I double checked and our IP is not on the blacklist and is properly whitelisted. We use hostgator for the site hosting. Could you recommend, since we dont use cloudflare, do you think we can resolve by incorporating IP's from our hosting into defender, or is there some other suggestion? thanks
    homepage: https://globalbiologics.us
    site login: https://globalbiologics.us/my-account/

  • Sean
    • New Recruit

    Patrick with support assisted to solve this issue. It was apparently an atypical problem relating to the Endurance cache used by hostgator, which all of a sudden conflicted with windows defender settings. At first, we presumed the problem was solved by clear all cache, disable the Endurance Cache plugin, deactivate & re-install Defender fresh but after a few minutes the problem recurred. It was eventually solved by changing the endurance cache to 'Off' in the WP Settings panel. appreciate the fast support.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.