Defender keeps writing the same rules but doesn't show resolved

I just installed defender into a this site and every time I try and do any of the .htaccess defender recommendations it keeps writing the same rules over and over again. I've tried to remove the these files (not sure if I've miis ed place or two) and tried again but with no luck. I've granted access to this site. Can you help?

  • Denitsa
    • WordPress Warrior

    Hello john_kesler,
    I hope you're having a beautiful day!

    If your .htaccess file contains the required rules but the notification is still there that usually means that your server doesn't allow these changes to be made from the .htaccess file.

    Could you get in touch with your hosting provider and check if that's indeed the case?

    Also, would you try running a quick troubleshooting by disabling your other plugins and check if it works after that?

    Let us know how it goes!


  • john_kesler
    • Design Lord, Child of Thor

    Haha I am the hosting provider. I had no problems with several other site on the same server and I’m pulling my hair out trying to track down what this might be. It's a site for my son’s birthday tomorrow and I would really like it if I could present it to him. This isn’t a blocker but it’s driving me crazy haha. I just stepped up the security on my server and here is the article I followed:

    I’ve undone most of it but it still is not cooperation. Any thoughts would be awesome.


  • Sajid
    • DEV MAN’s Sidekick

    Hello john_kesler,
    Hope you are doing good today :slight_smile:

    I am sorry to hear it is not working the way you are looking for. Could you please enable support staff access or better send us direct WordPress admin and FTP credentials so we could investigate it further.

    You can send the requested details via our secure contact form in following format.

    Subject: "Attn: Sajid Javed”
    - WordPress admin username
    - WordPress admin password
    - login url
    - FTP credentials (host/username/password)
    - link back to this thread for reference

    Also, please confirm that, by adding rules in .htaccess file, you mean the Prevent PHP execution or any other (please specify if it is a different action that writes rules multiple times) ?

    Take care and look forward towards your response :slight_smile:

    Best Regards,
    Sajid - WPMU DEV Support

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.