Defender Mask Login Redirect Traffic URL Invalid

Hello! I cannot find a valid format for the Redirect Traffic URL in Defender's Mask Login tool.

I've tried the following:

https://elementsteel.ca
https://elementsteel.ca/
https://elementsteel.ca/home/
https://elementsteel.ca/home
elementsteel.ca
/home/
home

It did occur to me that one can't redirect to home page but I figured I'd ask anyway. :slight_smile:

Thank in advance,

Lawrence

  • Ash
    • WordPress Hacker

    Hello Lawrence

    Yes, you are right. Currently, there is no way to redirect to the home page. But I just had a talk with the developer and he is going to fix this very soon :slight_smile: Currently, you need to set another page than home page.

    Thanks for mentioning and really appreciate your patience.

    Have a nice day!

    Cheers,
    Ash

    • Katya Tsihotska
      • Support & QA

      Hi Bill

      Hope you're well!

      You shouldn't use the full URL there, you can use a page slug. In the same way as in the Masking URLs field. E.g., if you have page http://domain.com/pageslug, you will need to use pageslug as the parameter

      If this doesn't work for you, please, contact our Live Support here https://premium.wpmudev.org/hub/support/#get-support so they can have a closer look at your site and help you with your issue.

      Kind regards,
      Katya

        • Katya Tsihotska
          • Support & QA

          Hi Sean

          Hope you're well!

          Thing is that there are 2 known issues with setting Redirect Traffic URL:
          1. It doesn't support dash-sign and other special characters, so you have to use slug which consists of letters and numbers only.
          2. It doesn't accept slugs of already existing pages. So you have to set the redirect URL and then create the suitable page. Or if you've already created the page, you can temporarily switch the slug to something else, set redirect URL and then switch the slug of the page back.

          Both issues will be solved in the next plugin version, so keep an eye on available updates.

          If nothing from the above doesn't help and you still cannot set the redirect URL, please contact our Live Support here https://premium.wpmudev.org/hub/support/#get-support so they can have a closer look at your site and help you with your query and if it will require things those are out of the scope of Live Support, they'll create a separate ticket for you.

          Kind regards,
          Katya

          • Sean
            • Design Lord, Child of Thor

            Thanks for the info! I discovered the "no dashes" issue when setting this up on another site. Looks like the issue I'm having is actually with the 404 Redirection URL. I've tried a full URL with and without trailing slash, and I've tried a slug. And THAT is what was giving me the error message. Also, leaving the Redirection field blank while still having 404 Redirection activated gives an error.

            What's the proper formatting for the 404 redirection URL?

          • Katya Tsihotska
            • Support & QA

            Hi Sean

            The formatting for 404 redirection URL in the current version of Defender (where we have bugs described above) is a slug of the page that doesn't exist on your site without dashes and other special characters. As an example, if you want to set the redirect to https://yourdomain.com/redirectpage, you have to set redirectpage as redirection URL parameter. And you have to create the page only after setting the redirect URL, otherwise, it will not allow you to save the URL if the page already exists on your site.

            If this still not work for you, the best course of action would be to contact one of our Support Experts via Live Support. That way, they can perform some preliminary troubleshooting and verification and also obtain any information needed to proceed with a fix for your particular situation.

            Also, it's just best to have your own thread for issues like this so that there's no confusion created and no undue notifications are sent to other members in the thread.

            Kind regards,
            Katya

          • Katya Tsihotska
            • Support & QA

            Hi Sean

            As I meantioned above, it's a bug in the Defender 1.8 and the workaround is to set the redirect first and then create the page with the needed slug. So the redirect won't result in 404.

            But actually, the new version of the plugin (1.9) has been released today and the mentioned issue was solved in this version. So after updating plugin to the latest version you shouldn't worry about this anymore and you can set the redirect to already existing page.

            Kind regards,
            Katya

          • Sean
            • Design Lord, Child of Thor

            I absolutely misread your last comment. Thanks so much for being patient and sorry for the confusion! I'm a huge fan of this feature and will definitely be using it along with Ultimate Branding to customize the user dashboard experience!

  • Grant
    • WPMU DEV Initiate

    We have the same issue here. We cannot enter any URL or slug for existing pages, non-existing pages, with or without trailing slashes, etc. Absolutely nothing works.

    The same issue occurs whether we have the 404 redirection enabled or not, and occurs on every website we've ever attempted this on. We've tried with several versions of Defender, including the latest one.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.