Defender Plugin doesn't send me reports

I'm having a problem with Defender Plugin, it stopped sending me the e-mail report, the last report was 6th April, please advice.

  • Adam Czajczyk

    Hello liz,

    I hope you're well today and thank you for your question!

    It seems that the reporting from Defeneder is currently scheduled for weekly e-mails. Those e-mails should be sent to a gmail address (your address that you will find at /wp-admin/profile.php). I understand that you have checked already that the messages are not being moved to the "spam" folder? I just want to make sure.

    Were you making any changes to the site around the time those mails stopped coming? I realize it was sometime ago but maybe you can recall if there were any updates done around that date or - more importantly - any customization made to site, like e.g. some custom code added or new plugins installed or some changes made to the server configuration?

    Let me know, please. I'm trying to "narrow down" the options here so we could investigate it further.

    Kind regards,
    Adam

  • Predrag Dubajic

    Hi Liz,

    I've done some additional tests on your installation and it seems that all of your emails are not being sent, not just Defender one.
    I have created a new account made sure that the option to notify me via email is enabled but nothing was sent.

    I then saw that you have configured WP SMTP plugin so I checked that and tried sending test email, which also failed.

    After the SMTP test there were a lot of Token has been expired or revoked. errors in the log so it seems that your SMTP plugin isn't configured properly.
    Can you check your settings in Settings > WP Mail SMTP and try to connect with Google again?
    After that test if new users are receiving an email and also see if Defender emails are being sent.

    Let us know how it goes.

    Best regards,
    Predrag

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.