[Defender Pro] Defender Authenticator not working

I keep getting
"Whoops, the passcode you entered was incorrect or expired."
I am entering correct code for google authenticator - I use it for all my other logins so I know how to use it.
I assume this is a bug, as when I tried to initially Add Defender 2FA, I kept on getting an error, but it would not let me off the profile page. After 10 times trying different things, 2FA was activated, but now i can not log in

I just need instructions on how to disable this plugin from console

  • FreeTV
    • New Recruit

    Please note that I was able to Deactivate the defender plugin from the Hub on this website

    I was able to re-active the plugin, but the 2FA part will not work. I keep getting "Your OTP code is incorrect. Please try again."

    I need 2FA - please let me know if this will be fixed soon

  • Bamboo Kit
    • Staff

    Hello, FreeTV

    I hope you’re well today and thank you for reply.

    I've looked into your Defender Pro issue, and see that most of our members who are facing this kind of issue have something to do with their server time, Timezone that are not related to the current time or Timezone.

    First, I'd like to ask you to check site's time zone and what current "local time" if it's a bit over a minute "behind" Google (the time that Google returns for your site's current time zone) the codes would actually expire before you even have a chance to use them. Google Auth app is using time from Google servers so if there are differences (note: I'm not talking about time zone, just strictly the time) this would be happening.

    That said, could you please double check with your provider if the time settings of the server (as it's a server-side thing) are correct? Also, I'm not sure whom are you hosting with but I found some interesting information about those "time sync" issues that affect certain hosting providers, mostly running CentOS - if they are running that OS it might be good to ask them to actually "reinstall tzdata in CentOS" (it's one of the packages of the operating system".

    Second, please change your server Timezone to your current Timezone, in order to do this, please follow the steps here: https://www.inmotionhosting.com/support/website/php/setting-the-timezone-for-php-in-the-phpini-file

    Hope this help, keep me updated.

    Kind regards,
    Bamboo

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.