[Defender Pro] Defender is causing wordpress errors and my site to run extremely slowly

My website is running exceptionally slow and the wordpress error log lists multiple errors being thrown off by Defender. Specifically, this error is occurring over and over
[Sat May 11 17:55:51.235436 2019] [access_compat:error] [pid 3928494:tid 140389419824896] [client 148.72.48.216:53987] AH01797: client denied by server configuration: /home/cwssz9ao64nt/public_html/403.shtml, referer: https://benxt.org/wp-content/uploads/wp-defender/index.php

  • Nithin
    • Support Wizard

    Hi Dan,

    [Sat May 11 17:55:51.235436 2019] [access_compat:error] [pid 3928494:tid 140389419824896] [client 148.72.48.216:53987] AH01797: client denied by server configuration: /home/cwssz9ao64nt/public_html/403.shtml, referer: https://benxt.org/wp-content/uploads/wp-defender/index.php

    The logs means the Defender is trying to protect the mentioned file from loading directly, which is part of the security feature of "Prevent PHP execution" in the plugin side. And the logs do point the fact that the "Prevent PHP Execution" security tweak is working fine.

    It shouldn't in general cause the website to slow down. Are there any other logs other than the mentioned one? Could I know where you are noticing the site to slow down? Is it in the frontend or backend?

    It seems like Defender Pro is no longer installed on your website. When I check pingdom test, I could still see the server is taking time to establish an initial connection.

    If you are still looking to troubleshoot this please do advise where you notice the issue, and also install the Defender plugin so that this could be looked upon.

    Regards,
    Nithin

  • Dan
    • Virtual Headshot Guy

    The site slowdown is site wide on both the admin dashboard and the front of the website.
    Also: I keep trying to use Defender's "security tweak" but it doesn't do anything when I press the button...it delivers a success message but does not actually update the .htaccess file and the tweak comes back as needing to be done.

  • Kris
    • Support

    Hi Dan

    To investigate this more and help you with this issue could you send below data.
    I would like to analyze those "security tweak" and also by you permission instal Query Monitor
    plugin which will help me diagnoze all process which exist in background when site is low.

    Also let me know which correct ""security tweaks" you try to activate.

    Please send it through our secure contact form here https://premium.wpmudev.org/contact/#i-have-a-different-question and make sure that subject is "I have a different question" and:
    - Mark to my attention: ATTN: Krzysztof Tomczyk
    - Site access (login url / username / password)
    - FTP credentials (host / username / password)

    - Link back to this thread

    Please confirm here in thread that you have sent that message.

    Kind Regards,
    Kris

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.