[Defender Pro] Defender Pro not loading after upgrade

Hi. We have recently upgraded our WordPress to version 5.2.4. Our Defender Pro is version 2.2.2. But I am unable to access the Dashboard or any of the Defender Pro pages. I can see the badge highlighting the number of issues I need to rectify, but I am unable to resolve them because I can’t access the Security Tweaks nor the Defender Pro Dashboard.

After I click on Defender Pro from the left-hand side menu, I can see the status bar (Waiting… Establishing connection etc) but after it stops, nothing is loaded in the main content window (right-hand side).

I tried to deactivate Defender Pro from Plugins and deleted the files (via Plugins). I reinstalled Defender Pro again (via Plugins) but this issue still persists.

Other actions I attempted but did not help:
– Logged in as a different user.
– Cleared browser cache and logged into WordPress in Incognito.

I am using Chrome version 77.0.3865 on Mac 10.13.6.
I have other sites using Defender Pro with no issues loading.

  • Adam Czajczyk
    • Support Gorilla

    Hello Zilin

    I hope you’re well today!

    Most likely the issue is caused by either some conflict (e.g. with other plugin) that started to happen after WP update or by higher resource (e.g. memory) usage.

    It’d be best to start with following steps:

    1) make sure about memory limit for WP; to do so:

    – go to the “WPMU DEV -> Support -> System Information” page in site’s “wp-admin” area
    – switch to “WordPress” tab there and look for the value of WP_MEMORY_LIMIT (not to be confused with WP_MAX_MEMORY_LIMIT)
    – it’d be safe to say that if it’s anything below 256M, it’s worth raising and to do that, simply add following line to the “wp-config.php” file of the site, above “/* That’s all, stop editing */”

    define('WP_MEMORY_LIMIT', '256M');

    2) if that doesn’t help, let’s look into WP internal debugging output; please add following lines to the “wp-config.php” file of the site, right above “/* That’s all, stop editing */”

    define( 'WP_DEBUG', true );
    define( 'WP_DEBUG_LOG', true );
    define( 'WP_DEBUG_DISPLAY', false );

    Once they are there, try accessing Defender pages in site’s back-end; there should still be the same issue going on but it should also cause WP to create a “debug.log” file in the “/wp-content/” folder. Please upload that file to some file storage of yours (like your Dropbox, Google Drive or similar space) and share direct link with me so I could take a look into it.

    Hopefully, this will give me some clue on why the issue is happening.

    Best regards,
    Adam

  • Zilin
    • New Recruit

    Hi Adam,

    (1) Memory limit updated to 256M but issue is unresolved.
    (2) Please see https://drive.google.com/open?id=1hbJQI8YqGhwZeQAD0KslXZ-hQk6CCnyU

    I noticed the log seems to point to a Hummingbird issue. I can load the Hummingbird Pro Dashboard from my Wp-Admin with no issues. I tried to deactivate Hummingbird and load Defender Pro Dashboard. But Defender Pro Dashboard still does not show up.

    Appreciate your help. Thanks so much!

    Best Regards,
    Zilin

  • Predrag Dubajic
    • Support

    Hi Zilin,

    Warnings shown in there shouldn’t affect Defender, especially when Hummingbird is disabled.
    Those warnings seem related to Page Caching, can you try disabling and enabling it to see if they stop showing after that?

    As for the Defender issue, did you try performing a full conflict test by disabling other plugins and switching to default WP theme to see if it works after that?

    If that doesn’t help could you provide us with FTP or cPanel access so we can investigate this further?
    Note: Don’t leave your login details in this ticket.
    Instead, you can send us your details using our contact form https://premium.wpmudev.org/contact/#i-have-a-different-question and the template below:
    Don’t change the selected topic in the dropdown, just leave it at “I have a different question”.

    Subject: “Attn: Predrag Dubajic
    – Site login URL
    – WordPress admin username
    – WordPress admin password
    – FTP credentials (host/username/password)
    – cPanel credentials (host/username/password)
    – Folder path to site in question
    – Link back to this thread for reference
    – Any other relevant urls/info

    Best regards,
    Predrag

    • Zilin
      • New Recruit

      Hi Predrag,

      Checked from Hummingbird Dashboard, Page Caching is not activated. I deactivated the entire Hummingbird plugin and the debug log still says

      Undefined index: compressed_size in …/wp-includes/class-wp-list-util.php on line xxx.

      How we resolved this issue:
      – We reverted to our back-up version of the site before the WP upgrade. Tested on a separate Staging URL (same server) so we will not affect our current LIVE site. Defender Pro loads fine.
      – Did the WP upgrade on the Staging site. Defender Pro still loads fine.
      – Migrated the Staging site contents to LIVE site. Defender Pro is working fine now.

      It might have been somewhere during/after the migration that caused the plugin to break. Nevertheless, a revert, test and migration round 2 works. Site is loading fine now.

      Thanks for all your kind assistance!

  • LSI
    • WPMU DEV Initiate

    I’m having the same issue, no defender pro pages will load. Enabled logging and debug.log has:
    [24-Oct-2019 12:52:07 UTC] PHP Fatal error: Call to undefined function WP_Defender\Behavior\determine_locale() in /httpdocs/wp-content/plugins/wp-defender/app/behavior/utils.php on line 1081

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.