[Defender Pro] "Mask Login Area" Bug

Has anyone noticed that when you mask the login area, it visually breaks the checkbox for "remember me?" Is this a bug or is it just me? This is a brand new multisite installation hosted by WMPUDEV.

  • Ohidul Islam
    • Staff

    Hey Teddy,

    Hope you are well today, thanks for your questions!

    Sorry, I have enabled Defender Pro Mask Login Area in my test site and I can’t reproduce the issue. Could you please confirm me that you are using latest version of Defender Pro?

    Also would you like to grant us Support access through WPMU DEV Dashbard > Support > Support Access so we could access your site securely and investigate further about this issue.

    And could you please attach a screenshot of broken “remember me?” checkbox so we could use this as a reference when we access your site?

    Best regards,

    Ohid

  • Ohidul Islam
    • Staff

    Hiya,

    Thank you for your response.

    I have checked your attached screenshot. It feels like there’s an additional rectangle box on top of the main checkbox.

    Sorry, I can not confirm how that checkbox styles got broken until I get access to your site and debug this further.

    Also could you please confirm us that, by deactivating “Mask Login Area” module from Defender Pro solves this issue?

    Please let me know when you enable support access and I will give it a shot. :slight_smile:

    Best regards,

    Ohid

  • Teddy
    • Flash Drive

    Yes, I can confirm that disabling the feature solves the problem, and that it reappears when I enable the feature.

    To clear things up, it happens with two sites currently hosted on WPMU DEV, neither of which are multisite. The multisite one actually seems to not have the issue even though it’s admin area is also masked.

    I have enabled access to both sites in question. Do you need anything else?

  • Ohidul Islam
    • Staff

    Hello Teddy,

    Thank you for updating us, hope you are well today!

    It seems like after activating the Mask Login Area feature the checkbox character code is missing somehow. Which is why it’s showing blank character code.

    Also sorry to inform you that, I do not see any Support access here. Could you please confirm that the site you have issue with checkbox is linked with your this WPMU Dev account and support access is granted for that?

    Would you please provide us a direct admin access username and password through a secure contact form to avoid Support access issue again that is happening with you? Also don’t forget to send both of your sites access having issue with checkbox so we will have investigate both and bring solutions for both of them.

    As this is a public forum, you should send us your details through our safe contact form

    https://premium.wpmudev.org/contact/#i-have-a-different-question

    using this template:

    Subject: “Attn: Ohidul Islam

    Site 01:

    – WordPress admin: (login URL)

    – Username:

    – Password:

    – link back to this thread for reference (https://premium.wpmudev.org/forums/topic/defender-pro-mask-login-area-bug)

    – any other relevant urls

    Site 02:

    – WordPress admin: (login URL)

    – Username:

    – Password:

    – link back to this thread for reference (https://premium.wpmudev.org/forums/topic/defender-pro-mask-login-area-bug)

    – any other relevant urls

    Keep in mind the subject line as ensures that it gets assigned to me.

    I will be waiting for the access to give it a shot :slight_smile:

    Best regards,

    Ohid

  • Ohidul Islam
    • Staff

    Hey Teddy,

    Thank you for your patience.

    We have investigated the issue and found that there was an issue with page and assets cache.

    So I have cleared the page caches from Hummingbird –> Caching and assets caches from Hummingbird –> Assets Optimization.

    Now the remember me checkbox is showing the checkmark icon as normal.

    Let me know if you have any more questions.

    Best regards,

    Ohid

  • Ohidul Islam
    • Staff

    Hi Teddy,

    Glad to hear back from you after a while. Hope you are doing good!

    As I can see from my last reply, this issue caused by some old caches. Could you please try clearing caches from Hummingbird –> Caching and assets caches from Hummingbird –> Assets Optimization.

    By doing this it solved the problem last time. I would ask you to try this solution again, if this doesn’t help then please reply with granting support access. So I would take a inside look at it.

    Cheers!
    Ohid

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.