Defender raised

Defender raised a couple of alerts but under the fix suggestion it says that my hosting service is not supported and to contact you. The two issues are:

Prevent Information Disclosure
Prevent PHP execution

    Vaughan

    Hi Liza,

    Hope you're well?

    Flywheel doesn't use htaccess at all as they use NGinx.

    They should be able to help with this though.

    Contact them and tell them you are wanting to add the following code to an htaccess in the following locations:

    /public_html/wp-content/.htaccess

    ## WP Defender - Prevent PHP Execution ##
    <Files *.php>
    Order allow,deny
    Deny from all
    </Files>
    ## WP Defender - End ##

    and in /public_html/.htaccess

    ## WP Defender - Prevent information disclosure ##
    <FilesMatch "\.(txt|md|exe|sh|bak|inc|pot|po|mo|log|sql)$">
    Order allow,deny
    Deny from all
    </FilesMatch>
    <Files robots.txt>
    Allow from all
    </Files>
    <Files robots.txt>
    Allow from all
    </Files>
    ## WP Defender - End ##

    They should hopefully then be able to add the equivalent to work with their flywheel nginx config.

    Hope this helps