Defender Scan Stuck at 0

Hi there!

I am trying to run Defender scan on this website but it has been stuck at 0 for over two hours.

At first I thought it may be because the website was in Maintenance Mode so I disabled this and tried to rescan but no luck.

I then followed the steps outlined in this Support post: https://premium.wpmudev.org/forums/topic/defender-scan-is-not-working

But still no luck.

Any ideas welcomed and gratefully received :slight_smile:

Best wishes
Joe

  • Rupok

    Hi Joe,

    So sorry to hear the inconvenience you are having. I tried to regenerate this issue on my test site but I could not. So I think, this is your site specific issue.

    Just to make sure no other plugin is causing this, especially caching plugins, can you please do a plugin conflict test? To know more about plugin conflict test, you can check this guide: http://premium.wpmudev.org/manuals/using-wpmu-dev/getting-support/

    Can you also turn on debug mode in WordPress and then try running the scan again? To enable it, open your wp-config.php file and look for define(‘WP_DEBUG’, false);. Change it to:

    define('WP_DEBUG', true);

    In order to enable the error logging to a file on the server you need to add yet one more similar line:

    define( 'WP_DEBUG_LOG', true );

    In this case the errors will be saved to a debug.log log file inside the /wp-content/directory.

    Depending on whether you want your errors to be only logged or also displayed on the screen you should also have this line there, immediately after the line mentioned above:

    define( 'WP_DEBUG_DISPLAY', false );

    The wp-config.php is located in your WordPress root directory. It’s the same file where the database configuration settings are. You will have to access it by FTP or SFTP in order to edit it.

    Past errors here. If the file is very long, paste them to a text file and attach with your reply.

    I could tell you better about the issue if I could see it live, check your current configuration and make some tests on your site. Would you mind allowing Support Access so we can have a closer look at this?

    To enable support access you can follow this guide here:
    http://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Please let us know the result of your plugin conflict test and debug data. Also confirm here when you are done granting Support Access. I'm looking forward to hearing from you and resolving this issue as soon as possible.

    Have a nice day. Cheers!
    Rupok

  • apurba_podder

    Hello Joe,
    Hope you are doing good today. :slight_smile:

    define('WP_DEBUG', true);
    define( 'WP_DEBUG_LOG', true );
    define( 'WP_DEBUG_DISPLAY', false );
    @ini_set( 'display_errors', 0 );

    Have you added this code in the wp-config.php file as Rupok said? If yes then please check the debug.log file in the wp-content folder. Otherwise open wp-config.php file & find 'define('WP_DEBUG', false);' replace this code with above mentioned code. Once done, cancel the existing scan, and then start the scan again. Then using FTP, you should now find a file called debug.log in your /wp-content/ folder. Please upload the debug.log file in Dropbox or google drive and give the download link here. This is the file which tells us the reason behind this issue.

    Please let us know how it went.

    Best Regards,
    Apurba

  • Kasia Swiderska

    Hello Joe,

    Can you contact your hosting provider and ask if you have mod_security enabled and if yes, could they for testing purposes disable it?
    Also can your check htaccess file with only a default WordPress entry https://codex.wordpress.org/htaccess#Basic_WP and see if this will fix issue?

    I'm asking about that because I checked browser console and I found there error:

    POST /wp-admin/admin-ajax.php 404 (Not Found)

    kind regards,
    Kasia