Defender session expired login

After enabled the security tweak "Manage Login Duration", once the session expired, I am not able to login again in the website, need to disable Defender.

  • Luís
    • Support

    Hi Barry - DSM ,

    What was the value entered in the "Manage Login Duration"? We already had a report regarding to "0", if you entered a value of "0" to the "number of days a user can stay logged in" it will avoid you to login again.

    In this case you may need to check the database and change the value in the "options" table. Check the "option_name" called "wd_hardener_settings" and all the hardener/Security tweaks values are inside the "option_value".

    If you have any doubt/difficulty in doing this, please send us the access to the database, so we can fix this for you. Please send it privately through our contact form:

    https://premium.wpmudev.org/contact/#i-have-a-different-question

    Send in:
    Subject: "Attn: Luis Lopes"
    - WordPress admin username
    - WordPress admin password
    - Login url
    - FTP credentials (host/username/password)
    - PHPMyAdmin credentials (host/username/password)
    - Link back to this thread for reference
    - Any other relevant urls/information

    Cheers, Luís

  • Luís
    • Support

    Hi Barry - DSM ,

    Hope you're doing well today!

    In my previous reply, I give you a suggestion in how to fix this issue, we had some similar reports where the users entered values to the "Manage Login Duration" option, like "0" or ".4" and this can cause issues in the login.

    However, this will require a change in the database to correct the values, so:

    1) Through PHPMyAdmin, select you database and navigate to the ""options" table.

    2) Make a search in the "option_name" field for "wd_hardener_settings".

    3) Check the string in the "option_value" field and correct the value for the "Manage Login Duration" security tweak.

    If you have any doubt/difficulty in doing this, please send us the access to the database following the procedure mentioned in my previous reply, so we can fix this for you:

    https://premium.wpmudev.org/forums/topic/defender-session-expired-login#post-1274540

    Cheers, Luís

  • Bob@MobiusIntelligentSystems.com
    • New Recruit

    Thank you, I was able to solve this problem by updating my logout time from .25 (6 hours) to 1 day via phpMyAdmin, but 24 hours is a long time. I hope that in the next update an option is provided for hours instead of days.

    I changed "login_duration_days" from .25 (see code below) to 1 to solve the problem

    wd_hardener_settings - phpMyadmin option_value
    A:11:{s:2:"id";s:20:"wd_hardener_settings";s:6:"issues";a:3:{i:0;s:10:"hide_error";i:1;s:12:"security_key";i:2;s:19:"protect-information";}s:5:"fixed";a:8:{i:0;s:17:"disable_trackback";i:1;s:10:"wp_version";i:2;s:11:"php_version";i:3;s:12:"change_admin";i:4;s:9:"db_prefix";i:5;s:19:"disable_file_editor";i:6;s:20:"prevent-php-executed";i:7;s:14:"login-duration";}s:6:"ignore";a:0:{}s:17:"last_status_check";i:1515545333;s:12:"notification";b:1;s:8:"receipts";a:0:{}s:4:"data";a:4:{s:17:"disable_trackback";i:1;s:27:"disable_trackback_post_keys";s:3:"yes";s:14:"login_duration";i:1;s:19:"login_duration_days";s:3:".25";}s:18:"exclude_file_paths";a:0:{}s:12:"new_htconfig";a:0:{}s:13:"active_server";s:6:"apache";}

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.