define( 'DISALLOW_FILE_EDIT', true ); error message visible

Hi, since installing Defender, I see this message both in the Dashboard and on the front end of the site:

define( 'DISALLOW_FILE_EDIT', true );

I’ve tried using the setting in Hardening to Disable the File Editor, but it just spins and never resolves. I’ve tried disabling Defender, but the error message still appears. Any help would be appreciated. Thanks!

  • wcg@uci
    • Site Builder, Child of Zeus

    I was able to fix it. It put the define( 'DISALLOW_FILE_EDIT', true ); before the beginning <?php tag in the wp-config.php file. Removing this fixed the issue. Our PHP version is 5.3.3, which may be part of the problem.

  • Vaughan
    • Support/SLS MockingJay

    Hi @sylviabass,

    Hope you’re well?

    Can you confirm you’re using the latest version of defender, our system is showing you as using 1.0.1.

    I just tried this on my install, and the define was added ok in the wp-config.php,but i’musing the latest release of the plugin.

    Either way though, it looks like you figured it out.

    I’ll keep an eye out for it happening again.

    Cheers

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.