deflate not enabling

I followed the troubleshooting steps. Added the script to enable the deflate module. My host doesn't disable this either. All other sites in my account does the same thing and they are all hosted on the same site.

  • Sajid

    Hello Edward,
    Hope you are doing good today :slight_smile:

    First of all, please make sure there is no other plugin with similar feature that may be conflicting with this plugin by running a plugin conflict test and also if you are using any cache plugin then make sure you purge all caches first.

    If that is not the case then follow the below troubleshooting options to make it work.

    The message suggests that the "mod_deflate" module may not be enabled but that may not always be the case. Please double-check your server for following issues as well:

    - check if there's a Varnish cache running on server (or any other server-side caching solution) and make sure to purge/empty it

    - make sure that PHP is configured to support zlib library and that zlib output support is enabled; there's a php.ini setting for this that should be set to "on":
    zlib.output_compression = On
    In case it's set to "off" you will want to change it to "on" and restart Apache

    - there's also a slight chance that not all required MIME types are set to be handled by "mod_deflate" module; it should support at least "text/html", "text/javascript" and "text/css"

    You may need to contact your hosting provider for these steps but I hope it'll fix the issue.

    Take care and have a nice day :slight_smile:

    Best Regards,
    Sajid - WPMU DEV Support

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.