Deprecated Values after Installing Supporter

Hi guys, just installed Supporter Plugin and activated debug after installation, lol. It is showing following Notices / Errors.

Notice: register_sidebar_widget is deprecated since version 2.8!<br />
Use wp_register_sidebar_widget() instead. in /home/sites/domain.com<br />
/public_html/wp-includes/functions.php on line 3237</p>
<p>Notice: register_sidebar_widget is deprecated since version 2.8!<br />
Use wp_register_sidebar_widget() instead. in /home/sites/domain.com<br />
/public_html/wp-includes/functions.php on line 3237</p>
<p>Notice: register_widget_control is deprecated since version 2.8!<br />
Use wp_register_widget_control() instead. in /home/sites/domain.com<br />
/public_html/wp-includes/functions.php on line 3237</p>
<p>Notice: is_site_admin is deprecated since version 3.0! Use is_super_admin()<br />
instead. in /home/sites/domain.com/public_html/wp-includes/functions.php<br />
on line 3237</p>
<p>Notice: Undefined variable: rebrand in /home/sites/domain.com/public_html<br />
/wp-content/mu-plugins/supporter-framework.php on line 230</p>
<p>Notice: Undefined variable: rebrand in /home/sites/domain.com/public_html<br />
/wp-content/mu-plugins/supporter-framework.php on line 230</p></p>
<p>Notice: has_cap was called with an argument that is deprecated since version<br />
2.0! Usage of user levels by plugins and themes is deprecated. Use roles<br />
and capabilities instead. in<br />
/home/sites/domain.com/public_html/wp-includes/functions.php on line 3321

There are two further Errors / Notices, please see attached images

Wordpress version : 3.0.4
Multi DB : Not Installed
No other Plugins installed, just supporter