Different durations per service

Dear Sirs

I have your Appointment+ v. 1.17 version and just updated to the newest version.

I have the time base set to 30 min. I also have a service with a 30 min duration.

I have now tried to add a new extra service on 60 min duration for certain service providers, but then the service providers with the 60 min service does not show up in front-end (you cannot choose them)

Can you help me to obtain different duration times for each service provider.
I have 6 providers and 3 of them need 30 min and the other 3 needs 60 min.

    Alexander

    Hi @Mikkel,

    I've tested this, and I can confirm we have a bug in the plugin. There are some issues related to assigning service providers to specific services.

    When working with multiple services and service providers, keep in mind if the user has selected a particular service, only the service providers who have that service assigned will be shown. In most cases, all service providers will be able to perform all services. Sometimes, like with your issue, this isn't the case.

    For now, would you be opposed to having a booking page for each service? We can set this up with some shortcodes. For example, if you modify your "Make an appointment" page, you can predefine a service to be used. Then you can remove the shortcode that allows a service to be selected. The schedule shortcode would need an attribute like this:

    [app_schedule service="3"]

    Hopefully this helps for now. In any case, I've reported this as a bug to the plugin developers.

    Best regards,

    pxwm

    Hi @Alexander Rohmann - I hope you don't kind me chiming in

    Hi @Mikkel

    You may wish to try the following if you haven't already done so:-

    Login to your Wordpress dashboard as Admin
    Select A+ Settings
    Select 'Add-ons' tab
    Activate the 'Durations' Add-on
    Then Select the 'General' tab
    You should then see a new field in the 'Time Settings' section called 'Time slot calculus method'
    Set this to 'Minimum time based appointment duration calculus (legacy)'.
    Then Save.

    Could you then try making an appointment.

    If this doesn't work could you please screenpost the following:-

    'Services' tab
    'Service Providers' tab
    'Working Hours' tab for all the Service Providers and the 'no specific provider'

    Regards
    SteveB

    Alexander

    Hi @Mikkel,

    I'm very sorry about the delay here. Yes, this is possible, you just need to include worker and provider ids in a shortcode. Create a page with these codes:

    [app_schedule worker="1" service="1"]
    [app_confirmation]

    For a monthly view, you can use the monthly version of the schedule shortcode instead:

    [app_monthly_schedule worker="1" service="1"]
    [app_confirmation]

    The worker attribute needs to be the ID of the service provider for whom you are creating this page. The service should be set to the ID of the service you're intending to show. You can find these IDs in the leftmost column on the screens where you can edit them.

    I'm still waiting to hear back from the developer regarding the bug here.

    Best regards,