Different sitemaps for two languages in a WP Multisite

Hello all,

I have a WP Multisite install with three sites.
Site 1 is total site in English
Site 2 is total site in Spanish
Site 3 is holder site (used as primary domain and redirects with a hack to en or es site).

The sites are installed in subdirectories (/es/ and /en/)

I have installed Infinite SEO.
The sitemaps for the seperate sites seems not to work. I only get a URL of the XML file to the English version. The Spanish version doesn't show up. I want to have two XML files for two different languages.

Any idea how to fix it? Or use Simple Multi Site Sitemap instead?

Greetings,
Jonathan Fokker

  • Tanmay
    • Flash Drive

    Hello @Jonathan Fokker and warm welcome to WPMU Dev.

    The sitemap files themselves cannot reference URLs that are outside of the directory tree/subdirectory in which they are located.

    i.e. A Sitemap file located at http://yourdomain.com/en/sitemap.xml can include any URLs starting with http://yourdomain.com/en/ but can not include URLs starting with http://yourdomain.com/es/.

    I would suggest you to use Simple Sitemap for Multisite. :slight_smile:

    If you need further assistance, feel free to post.

    Have a nice day.

  • Jonathan Fokker
    • Design Lord, Child of Thor

    Thanks.

    That's weird. I checked it with another Multisite install of mine and there I used Infinite SEO as it has created two seperate XML files yourdomain/es/sitemap.xml and yourdomain/en/sitemap.xml.

    That's exactly what I want.

    This are the steps I took:
    I network activated Infinite SEO.
    Specified which fields seperate sites can use
    Disabled multisite wide with line in wp-config.

    Exactly the same as with the other Multisite installation.

    When trying with Simple Sitemap he produces two separate multisite, but they are the same.
    What am I doing wrong?

    Greetings,
    Jonathan

  • aecnu
    • WP Unicorn

    Greetings Jonathan Fokker,

    I checked it with another Multisite install of mine and there I used Infinite SEO as it has created two seperate XML files yourdomain/es/sitemap.xml and yourdomain/en/sitemap.xml.

    That's exactly what I want.

    This should work as you have described above and the concept of the URL's is exactly correct.

    Disabled multisite wide with line in wp-config.

    What is the purpose in doing this?

    Thank you for being a WPMU Dev member!

    Cheers, Joe :slight_smile:

  • Tanmay
    • Flash Drive

    Greetings @Jonathan Fokker

    Thank you for detailed response. Sorry to confuse you, my bad. Infinite SEO is perfectly compatible with WP multisite. (Disabling multisite wide in wp-config.php will switch from network-wide mode to site-par mode).

    Steps you took are perfect. Any luck with your current installation? Let us know.

    Take care.

  • aecnu
    • WP Unicorn

    Greetings Jonathan Fokker,

    Please let us know if this does not resolve your problem by reopening this ticket below marking it as not resolved. Also please indicate if there are any new symptoms or errors.

    Thank you for being a WPMU Dev member!

    Cheers, Joe :slight_smile:

  • Jonathan Fokker
    • Design Lord, Child of Thor

    He all,

    Thanks for your feedback. I still have the problem.

    What did I do:
    I network activated Infinite SEO.
    Specified which fields seperate sites can use
    Disabled multisite wide with line in wp-config.

    When going to the English site I see this path for the XML:
    /home/redes751/public_html/islascanariasinternet.com/wp-content/blogs.dir/3/files/sitemap.xml

    And this URL:
    http://www.islascanariasinternet.com/en/sitemap.xml

    When going to the Spanish site I see this path for the XML:
    /home/redes751/public_html/islascanariasinternet.com/wp-content/blogs.dir/3/files/sitemap.xml

    And this URL:
    http://www.islascanariasinternet.com/en/sitemap.xml

    As you can see they are exactly the same! What am I missing here?

    Greetings,
    Jonathan

  • Tanmay
    • Flash Drive

    Hello @Jonathan Fokker,

    I checked your website, great work, I must say.

    Strange thing I noticed about http://www.islascanariasinternet.com/en/sitemap.xml is showing sitemap for /es/ directory.

    Do one thing, for English site, change path for the XML to:

    /home/redes751/public_html/islascanariasinternet.com/wp-content/blogs.dir/2/files/sitemap.xml

    The problem is occurring, may be, because you are not providing different blog directory path of xml for different site.

    Try it out, and let me know. :slight_smile:

    Take care.

  • Jonathan Fokker
    • Design Lord, Child of Thor

    Thanks for the feedback!

    Tried it but didn't work.

    Very weird. No /es/ sitemap. /en/ is created but once I open it from the admin window in Infiniteo SEO in the English site it give me the right en urls.
    But when opening Infiniteo SEO in the Spanish site, it give me the es urls. Very weird.

    Any other options?

    Greetings,
    Jonathan

  • aecnu
    • WP Unicorn

    Greetings Jonathan Fokker,

    Please try the following and let me know the results at your earliest convenience.
    Infinite SEO not network activated.

    Then site activate it for each site and please let me know if this fixes the maps into the two separate languages respectively and properly.

    Thank you for being a WPMU Dev member!

    If we can be of further assistance please let us know.

    Cheers, Joe :slight_smile:

  • aecnu
    • WP Unicorn

    Greetings Jonathan Fokker & Tanmay,

    Please be advised about this 100% relative article on a Infinite SEO bug:
    https://premium.wpmudev.org/forums/topic/sitemap-little-bug-and-how-to-solve-it

    To ease the pain and assist looking through the database I offer you to download in what is in my opinion the greatest Database Management software of all time Navicat.

    Thank you for being a WPMU Dev member!

    Please let us know if this does not resolve your problem by reopening this ticket below marking it as not resolved. Also please indicate if there are any new symptoms or errors.

    Cheers, Joe :slight_smile:

  • aecnu
    • WP Unicorn

    Greetings Jonathan Fokker,

    Thank you for being a WPMU Dev member!

    Sorry for the delay here - first you want to make sure the Infinite SEO plugin is allowed to be site by site activated.

    Are you running pro Sites by any chance?

    Cheers, Joe :slight_smile:

  • aecnu
    • WP Unicorn

    Greetings Jonathan Fokker,

    Just checking if this issue was eventually resolved in another thread? Or by yourself separately to us? Or by us over email with you? Or using our live support?

    If so, no need to reply, that's great news.

    If not, or you have any more questions related to this thread, please feel free to post them below including any new symptoms or errors and tick the 'Mark as Not Resolved (re-open)' box below the post area (or else we'll miss it!)

    Otherwise, happy days, glad you got it sorted :slight_smile:

    Thank you for being a WPMU Dev member!

    Cheers, Joe :slight_smile:

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.