Different Website: contact form not working?

Hi,

Recently I had submitted a ticket on “unknown contact form” for our site, avia.ainterpreting.com, to which I received a response that multi-forms are not doable, only one form.

So now with that in mind, I am trying to add a new contact form on a separate website, new.ainterpreting.com, which is a separate entiety from the previous website. And it provides this error message, “unknown contact form”.

I dont want to assume here but both sites are still linked because they share the same domain name even though there’s no direct links between them, hence only one form works, am I right?

Can you pls look into this and confirm for me?

thanks,

Smitha

  • Nastia
    • Support Rock Star

    Hello Smitha Hanumantha

    I trust you re doing well today!

    I suppose you’re referring to the Fixer’s built-in contact form, right?

    So now with that in mind, I am trying to add a new contact form on a separate website, new.ainterpreting.com, which is a separate entiety from the previous website. And it provides this error message, “unknown contact form”.

    Please let me know under what conditions you see this error. Because I can’t reproduce this on your site, I dragged and dropped the contact element and sent an email from a test user with no issue.

    Please let me know where are you trying to add the contact element?

    You can try the Contact 7 plugin on your site. Create as many forms you need and use contact form shortcode inside a text element.

    Please advise,

    Cheers,

    Nastia

  • Smitha Hanumantha
    • Site Builder, Child of Zeus

    Hi,

    By the time you checked into that page, I had removed the contact form (since it was no longer working) and embedded a form from TypeForm, which is working.

    However, to show you the error message I mentioned — for the time being, I put the contact from from the UPfront theme onto a specific page — http://new.ainterpreting.com/privacy-inner/

    As you will see when you fill out the form, it provides an output of “unknown contact form”.

    Can you pls look into this?

    Thanks,

    Smitha

  • Sajid
    • DEV MAN’s Sidekick

    Hi Smitha Hanumantha,

    Hope you are doing good today :slight_smile:

    It appears that you have grouped the contact form with other elements on the page. We have reported this issue before and our developers working on to fix this issue.

    Meanwhile, please ungroup the contact form with other elements and it should work fine then.

    Hope that helps! Feel free to post a reply if you need further assistance :slight_smile:

    Best Regards,

    Sajid

  • Nastia
    • Support Rock Star

    Hello Smitha Hanumantha

    I hope you are doing well today!

    Just click on the grouped elements, the “Ungroup” button will appear, and click on it to ungroup the them.

    I’ve created a small screencast:

    https://monosnap.com/file/k6sTZr9aK74URpHu51r59dzS6FdQ1p

    However, I visited your page and the contact form is not grouped with other elements.

    Once I reproduced this error on your site, the a 500 error appeared in the developer console:

    Failed to load resource: the server responded with a status of 500 (Internal Server Error)

    Would you please run a quick check for a conflict with another plugin or theme.

    Deactivate all the plugins and test if the contact from is working. If everything is well, activate one plugin at a time to find the one that causes this.

    Follow the flowchart from our Getting Support manual:

    https://premium.wpmudev.org/manuals/using-wpmu-dev/getting-support/

    Le us know how it went!

    Cheers,

    Nastia

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.